summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-01-21 21:48:15 +0100
committerDavid Seifert <soap@gentoo.org>2019-01-21 21:49:08 +0100
commit90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3 (patch)
treec8609a6eb11f9ecdbddb57c30a2ce9af8b11beb7
parentapp-eselect/eselect-ruby: fix broken manifest (diff)
downloadgentoo-90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3.tar.gz
gentoo-90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3.tar.bz2
gentoo-90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3.zip
dev-python/pkgconfig: Version bump to 1.4.0
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/pkgconfig/Manifest1
-rw-r--r--dev-python/pkgconfig/pkgconfig-1.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pkgconfig/Manifest b/dev-python/pkgconfig/Manifest
index e9a9e0e3e786..845f68183b69 100644
--- a/dev-python/pkgconfig/Manifest
+++ b/dev-python/pkgconfig/Manifest
@@ -1 +1,2 @@
DIST pkgconfig-1.2.2.tar.gz 5305 BLAKE2B 39fe5e05489e4eb8fefce66f23820d96039f5dfb82148e8ac2d691644aa2d4f1205bfa483f9fdc69837b7956834d1525d85281ba6aa0a0c079748336d47708c7 SHA512 88cfb27755297871c500f37c422da5d4ae30a14e0b9974afbe63f22c59746be0d175b65d9e3d2ed315b4d942046e7c18be062aef914199c99070a2767699848b
+DIST pkgconfig-1.4.0.tar.gz 5915 BLAKE2B 17ae11783b6642f6c8e726b42b725b7904ea282829b4527f92daa1e6ea43c3c126e6ef7e29fe5eefc89b40f3b69799087a46df6ac5695a593903dab9dc247c04 SHA512 8a270449b7b8b850aab9cc5774d1d6c6b68254f00157b66530c15697eda214948d3a71a75725067d63b906a9c3b1d789a775ac15a1094ff5ba3f227bcd666528
diff --git a/dev-python/pkgconfig/pkgconfig-1.4.0.ebuild b/dev-python/pkgconfig/pkgconfig-1.4.0.ebuild
new file mode 100644
index 000000000000..1823ef123659
--- /dev/null
+++ b/dev-python/pkgconfig/pkgconfig-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface Python with pkg-config"
+HOMEPAGE="https://pypi.org/project/pkgconfig/ https://github.com/matze/pkgconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -e '/nose/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die
+}