summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-16 06:42:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-16 07:04:56 +0200
commit90d68180b8443b8213092874742729f2d25f8e71 (patch)
tree697887a2c889ad647891914e9c8e568811de9db0
parentdev-python/ipykernel: Bump to 6.23.1 (diff)
downloadgentoo-90d68180b8443b8213092874742729f2d25f8e71.tar.gz
gentoo-90d68180b8443b8213092874742729f2d25f8e71.tar.bz2
gentoo-90d68180b8443b8213092874742729f2d25f8e71.zip
dev-python/sentry-sdk: Bump to 1.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.23.0.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index d8fed873a65c..4b8573d3097c 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -4,3 +4,4 @@ DIST sentry-python-1.21.0.gh.tar.gz 346948 BLAKE2B 7d4d9d537d567c930187d74fc46be
DIST sentry-python-1.21.1.gh.tar.gz 349021 BLAKE2B f467ba16484d0807734deb7d2544f32addeac254dbac02d5c56d5c9d05081d1c38665f7a5eb14ff59dd4b39ecb25d922b60a0d18fc98290c0127142cf5bb89d0 SHA512 04f56fa1a53ad42baaf09fb4b19a29c009e2a956ee363d6003746d993d1d8b4af37b8458bf8b04255cd72083bdf0c35b4244d6aabf26110ff6a0d245ce674c58
DIST sentry-python-1.22.1.gh.tar.gz 351929 BLAKE2B afcdd6293ff1e96f2a07e6d6ad5fb9bfc8715cf4d7ca30237d92cae9f48abf4cb849ad8f86f3ba3f0421198dd2fdbfe25b95c9e50c2abab36d1fed4bd71181fd SHA512 2796620223476d8996291d2f2ff88a128a86fe8ded40f44ffc575f09e8b390d9b0e77e186d153decb81f33aa050eeef5b2ce707ad381d226955ce18315a0e3ee
DIST sentry-python-1.22.2.gh.tar.gz 352403 BLAKE2B 7dcc1583904ac7ca2349b153c13ffd2098e888fcf18a7150efa8e99e0bdc93f40c2d91a0044b85d64e21116e2503173e8a0b46dcc227f7e5cf7deaf2fe8abc64 SHA512 71d4235a0a5f6df0e18f0f0e04530ce225c218cc1018d48c7a419f3a118ea9d89df3635d62ae2a5a34632a58163ac317f41167e40b2ea172f2bd0467de3a8196
+DIST sentry-python-1.23.0.gh.tar.gz 355085 BLAKE2B a0cab2f69177325a28b6fc24aa311f3ab9bdb20b43c9cbcf809a67aaaeb51306cabc2f7ce413ec9e85de6d1283a2f0d7c3cf7c0d3f8df84c54cf8f685025e127 SHA512 6cb0fda5c73e7f3a3e33458479ab40f6f33c661b9ddf69eaf6630c22004ff8a21157a3be454e583717b7d1999bff26bbe8d8e3d719e42c42612f1c5ddf0767b5
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.23.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.23.0.ebuild
new file mode 100644
index 000000000000..8095ec3baba2
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.23.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
+ tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
+ tests/test_scrubber.py::test_span_data_scrubbing
+)