summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-04-12 17:35:17 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2020-04-12 17:35:17 +0200
commit92dd380339eac1492a43989776cd5ff861d0e078 (patch)
tree553f4af0eaf250842cd1552a30c89768f8d95bc9
parentdev-python/setuptools_scm: Hard-block ancient versions (diff)
downloadgentoo-92dd380339eac1492a43989776cd5ff861d0e078.tar.gz
gentoo-92dd380339eac1492a43989776cd5ff861d0e078.tar.bz2
gentoo-92dd380339eac1492a43989776cd5ff861d0e078.zip
media-radio/wsjtx: Fix build with QT_VERSION >= 5.14
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch20
-rw-r--r--media-radio/wsjtx/wsjtx-2.1.2.ebuild5
2 files changed, 23 insertions, 2 deletions
diff --git a/media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch b/media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch
new file mode 100644
index 000000000000..553a3bcb650f
--- /dev/null
+++ b/media-radio/wsjtx/files/wsjtx-2.1.2-qt_helpers.patch
@@ -0,0 +1,20 @@
+# build with newer qt-5.14
+# patch provided by nrdufour at the wsjtx mailing list
+--- a/qt_helpers.hpp 2019-11-26 09:22:32.000000000 -0500
++++ b/qt_helpers.hpp 2020-02-03 11:30:07.488214336 -0500
+@@ -83,6 +83,7 @@
+ // std::hash<> specialization for QString based on the dbj2
+ // algorithm <http://www.cse.yorku.ca/~oz/hash.html> because qHash()
+ // is poor on 64-bit platforms due to being a 32-bit hash value
++ #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+ template<>
+ struct hash<QString>
+ {
+@@ -96,6 +97,7 @@
+ return hash;
+ }
+ };
++#endif
+ }
+
+ // Register some useful Qt types with QMetaType
diff --git a/media-radio/wsjtx/wsjtx-2.1.2.ebuild b/media-radio/wsjtx/wsjtx-2.1.2.ebuild
index 15c7d5cf22d8..b1d82d5b375b 100644
--- a/media-radio/wsjtx/wsjtx-2.1.2.ebuild
+++ b/media-radio/wsjtx/wsjtx-2.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,7 +39,8 @@ S=${WORKDIR}/wsjtx
PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
"${FILESDIR}/${PN}-fix-unicode.patch"
- "${FILESDIR}/${PN}-drop-docs.patch" )
+ "${FILESDIR}/${PN}-drop-docs.patch"
+ "${FILESDIR}/${PN}-2.1.2-qt_helpers.patch" )
DOCS=( AUTHORS BUGS NEWS README THANKS )