summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-12-12 15:41:59 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2020-12-12 16:09:10 +0100
commit92df42df52f4313bf8263d91c1207253a779eb88 (patch)
tree7008dd1bffe9f99ca86fb3826cf66be46f1c5d9b
parentdef-python/fcl: drop old (diff)
downloadgentoo-92df42df52f4313bf8263d91c1207253a779eb88.tar.gz
gentoo-92df42df52f4313bf8263d91c1207253a779eb88.tar.bz2
gentoo-92df42df52f4313bf8263d91c1207253a779eb88.zip
def-python/fcl: fixed linking with lld
Closes: https://bugs.gentoo.org/743247 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18618 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--dev-python/fcl/fcl-0.0.12-r1.ebuild2
-rw-r--r--dev-python/fcl/files/fcl-0.0.12-fix-compiling-on-lld.patch12
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/fcl/fcl-0.0.12-r1.ebuild b/dev-python/fcl/fcl-0.0.12-r1.ebuild
index 960dd71a4e0c..27910fbb1371 100644
--- a/dev-python/fcl/fcl-0.0.12-r1.ebuild
+++ b/dev-python/fcl/fcl-0.0.12-r1.ebuild
@@ -27,6 +27,8 @@ RDEPEND="
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-fix-compiling-on-lld.patch )
+
distutils_enable_tests unittest
python_test() {
diff --git a/dev-python/fcl/files/fcl-0.0.12-fix-compiling-on-lld.patch b/dev-python/fcl/files/fcl-0.0.12-fix-compiling-on-lld.patch
new file mode 100644
index 000000000000..0e3cf7a54196
--- /dev/null
+++ b/dev-python/fcl/files/fcl-0.0.12-fix-compiling-on-lld.patch
@@ -0,0 +1,12 @@
+--- a/setup.py
++++ b/setup.py
+@@ -21,8 +21,7 @@
+ include_dirs = ['/usr/include',
+ '/usr/local/include',
+ '/usr/include/eigen3']
+- lib_dirs = ['/usr/lib',
+- '/usr/local/lib']
++ lib_dirs = ['/usr/local/lib']
+
+ if 'CPATH' in os.environ:
+ include_dirs += os.environ['CPATH'].split(':')