summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-03-06 17:00:37 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-03-06 17:03:53 +0100
commit92f585449ef07f1590c69e67c078f84572824bcf (patch)
treec64af94d7167ed29e6624d23fcb826ebddbfc2e9
parentmedia-sound/upmpdcli: Remove old (diff)
downloadgentoo-92f585449ef07f1590c69e67c078f84572824bcf.tar.gz
gentoo-92f585449ef07f1590c69e67c078f84572824bcf.tar.bz2
gentoo-92f585449ef07f1590c69e67c078f84572824bcf.zip
dev-php/pecl-apcu: bump to v5.1.20
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-php/pecl-apcu/Manifest1
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index ee5a4d2cf52c..fdb813bf4adf 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -1 +1,2 @@
DIST apcu-5.1.19.tgz 96583 BLAKE2B 330c08a4e557691d0b402111877b3caf56b211256db17cce52a76aeefce7237505eca4ecd71f3770ef3c405182a1604a92cc458cb9bca435b42370fe917e21a7 SHA512 45077e3bd0eac207539e2eafe21968c71f49b8c8920168dbafa87961b041f1d348b6bf1c130104744bc541e1f690854f0a29062e9520db81c04edeee3ef2ed99
+DIST apcu-5.1.20.tgz 96727 BLAKE2B b8223856e0aaa52f90dffa674bbd9b047caa8c91d81b637eafc2f59fbbfdfe0d6ce30e990a87cb4833e895fcfd944f7d57eb6f7356b3e2361d6be5a535bb3a63 SHA512 3e10b7e5dc7481b1250610ef83954875f427b9114d6b232bad9064fc33d8c8906bcc317f94a6cfc9f76c720fa06a44270d259cf2ceef6c1ec9dcadc49254ee1b
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild
new file mode 100644
index 000000000000..d36dd950e472
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.20.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( NOTICE README.md TECHNOTES.txt )
+
+USE_PHP="php7-2 php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+LICENSE="PHP-3.01"
+SLOT="7"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock-${l} "
+done
+
+IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+ # Remove broken tests from php 7.4 due to trivial output differences
+ if use php_targets_php7-4 ; then
+ php_init_slot_env "php7.4"
+ rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-apcu
+ $(use_enable mmap apcu-mmap)
+ $(use_enable lock-spinlock apcu-spinlocks)
+ )
+ # Broken upstream autoconf test disables if present at all
+ use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r3_src_install
+
+ insinto /usr/share/php7/apcu
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
+ elog
+ elog "If you depend on the apc_* functions,"
+ elog "please install dev-php/pecl-apcu_bc as this extension no longer"
+ elog "provides backwards compatibility."
+}