summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-25 21:06:07 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-25 21:06:07 +0100
commit936d0ed3aaface3a953ea2fe9d228f00ca4e8dae (patch)
treec47b2b30b94217f6f391f7bda0a860c748ad1b56
parentdev-python/pylibacl: Stabilize 0.6.0 ppc64, #762526 (diff)
downloadgentoo-936d0ed3aaface3a953ea2fe9d228f00ca4e8dae.tar.gz
gentoo-936d0ed3aaface3a953ea2fe9d228f00ca4e8dae.tar.bz2
gentoo-936d0ed3aaface3a953ea2fe9d228f00ca4e8dae.zip
www-apps/nextcloud: add post-install doc warning
Closes: https://bugs.gentoo.org/762388 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--www-apps/nextcloud/files/php-argon2-en.txt11
-rw-r--r--www-apps/nextcloud/nextcloud-18.0.12.ebuild4
-rw-r--r--www-apps/nextcloud/nextcloud-18.0.13.ebuild2
-rw-r--r--www-apps/nextcloud/nextcloud-19.0.6.ebuild4
-rw-r--r--www-apps/nextcloud/nextcloud-19.0.7.ebuild2
-rw-r--r--www-apps/nextcloud/nextcloud-20.0.4.ebuild4
-rw-r--r--www-apps/nextcloud/nextcloud-20.0.5.ebuild2
7 files changed, 26 insertions, 3 deletions
diff --git a/www-apps/nextcloud/files/php-argon2-en.txt b/www-apps/nextcloud/files/php-argon2-en.txt
new file mode 100644
index 000000000000..44d6487890da
--- /dev/null
+++ b/www-apps/nextcloud/files/php-argon2-en.txt
@@ -0,0 +1,11 @@
+Migrating from an existing Nextcloud deployment
+
+if you migrate data from a previously existing Nextcloud deployment, you may
+need to enable USE=argon2 on dev-lang/php (if previous system ran on a php
+version using this hashing algorithm)
+
+This is not listed in ebuild requirements as this will not be required for
+most systems (new installs and some migrations)
+
+More details in bug:
+https://bugs.gentoo.org/762388
diff --git a/www-apps/nextcloud/nextcloud-18.0.12.ebuild b/www-apps/nextcloud/nextcloud-18.0.12.ebuild
index de1b7898efdf..0aa3ba1808c6 100644
--- a/www-apps/nextcloud/nextcloud-18.0.12.ebuild
+++ b/www-apps/nextcloud/nextcloud-18.0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,5 +37,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/config
webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
webapp_src_install
}
diff --git a/www-apps/nextcloud/nextcloud-18.0.13.ebuild b/www-apps/nextcloud/nextcloud-18.0.13.ebuild
index f4ace9730f93..0aa3ba1808c6 100644
--- a/www-apps/nextcloud/nextcloud-18.0.13.ebuild
+++ b/www-apps/nextcloud/nextcloud-18.0.13.ebuild
@@ -37,5 +37,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/config
webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
webapp_src_install
}
diff --git a/www-apps/nextcloud/nextcloud-19.0.6.ebuild b/www-apps/nextcloud/nextcloud-19.0.6.ebuild
index de1b7898efdf..0aa3ba1808c6 100644
--- a/www-apps/nextcloud/nextcloud-19.0.6.ebuild
+++ b/www-apps/nextcloud/nextcloud-19.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,5 +37,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/config
webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
webapp_src_install
}
diff --git a/www-apps/nextcloud/nextcloud-19.0.7.ebuild b/www-apps/nextcloud/nextcloud-19.0.7.ebuild
index f4ace9730f93..0aa3ba1808c6 100644
--- a/www-apps/nextcloud/nextcloud-19.0.7.ebuild
+++ b/www-apps/nextcloud/nextcloud-19.0.7.ebuild
@@ -37,5 +37,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/config
webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
webapp_src_install
}
diff --git a/www-apps/nextcloud/nextcloud-20.0.4.ebuild b/www-apps/nextcloud/nextcloud-20.0.4.ebuild
index de1b7898efdf..0aa3ba1808c6 100644
--- a/www-apps/nextcloud/nextcloud-20.0.4.ebuild
+++ b/www-apps/nextcloud/nextcloud-20.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,5 +37,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/config
webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
webapp_src_install
}
diff --git a/www-apps/nextcloud/nextcloud-20.0.5.ebuild b/www-apps/nextcloud/nextcloud-20.0.5.ebuild
index f4ace9730f93..0aa3ba1808c6 100644
--- a/www-apps/nextcloud/nextcloud-20.0.5.ebuild
+++ b/www-apps/nextcloud/nextcloud-20.0.5.ebuild
@@ -37,5 +37,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/config
webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
webapp_src_install
}