summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-14 09:29:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-14 09:35:39 +0100
commit9381f6e9c89ec290ab7d88e82b43b03b904535ca (patch)
treeeab762cfbe3dcc4918b8473073e16fedff5fa5ef
parentdev-python/setuptools_scm: Bump to 5.0.1 (diff)
downloadgentoo-9381f6e9c89ec290ab7d88e82b43b03b904535ca.tar.gz
gentoo-9381f6e9c89ec290ab7d88e82b43b03b904535ca.tar.bz2
gentoo-9381f6e9c89ec290ab7d88e82b43b03b904535ca.zip
dev-python/wheel: Bump to 0.36.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.36.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index 23434ac64934..a7c35f1fb5d7 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,3 +1,4 @@
DIST wheel-0.35.1.gh.tar.gz 63563 BLAKE2B d1432a638b91e821cb9b9fc748567b9ad18bbfd4737cee915ee3e2c585c4758e79bcf163edac56a09f9e356d81a057214c8e84c5c75b45505c67aa761e97fe3f SHA512 34cd6d1a649842abd895418c0183e68f44e228be905041e1dd8562987fbab8aa617da9b78479cb8d56fb6bb8714ec1085b87640c385bfc933e215f6e33ccf55b
DIST wheel-0.36.0.gh.tar.gz 65186 BLAKE2B 384dea20a6fdc2e9cc581c1e30814ac84285b8ca2ac5588fc837a1e27add493dedd38ead643776d1353a98cafa45a609e9655168fd09944cfe016d99e357fcd2 SHA512 1f851dfc18fa96d67bb96c61eec15999c46ea77c490173b71121810480f3c30f2de770a2e6e0712d04f35c91fcadbb276b05968e2b5db76dea882929f555f983
DIST wheel-0.36.1.gh.tar.gz 65846 BLAKE2B 906bd8887ab0efc6542547c603d613e6b12e4ea56e8d037c3a4532e064f3d337cd5c161e2c2557cc832262a42eeda2850303f1d92e8de45f44321ebc9d47c955 SHA512 1f9a27604b0fa0d1ae4782bdba57956a70d74a9a736f4c41481b417cd1e8a86938705555c37835ffe1a061ef55f8adad3475bfc20e2c1fd8de8083dd5c72cca0
+DIST wheel-0.36.2.gh.tar.gz 67999 BLAKE2B 0bb6742ddb25a5b94f94fd071dfe63ae5fa555731625b4b8ca2c7abb1a255e24590ae9ea250ada0473fcd74f19bdca7e529f8eda1a79d8e394d8b339bd2a257a SHA512 23f3dd0540ecc8e762f37a4bb69713abe99125a605c03b1a3412cec910fb7a6cea3eee3910d7c98122b276170a17414c9132b57b57a30a4ba1283cea8f9e20fa
diff --git a/dev-python/wheel/wheel-0.36.2.ebuild b/dev-python/wheel/wheel-0.36.2.ebuild
new file mode 100644
index 000000000000..22ddbb0304ee
--- /dev/null
+++ b/dev-python/wheel/wheel-0.36.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ if ! python_is_python3; then
+ # install fails due to unicode in paths
+ ewarn "Testing is broken with py2.7, please test externally"
+ return
+ fi
+
+ distutils_install_for_testing --via-root
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}