summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-31 06:52:13 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-31 10:08:50 +0200
commit94b007ee239c170f0300e790aa9853e0f3df1139 (patch)
tree739239299adfa222dc7e67bc072de65f1cdea7ed
parentdev-python/pytest-mock: Keyword 3.1.0 ppc ppc64, #726348 (diff)
downloadgentoo-94b007ee239c170f0300e790aa9853e0f3df1139.tar.gz
gentoo-94b007ee239c170f0300e790aa9853e0f3df1139.tar.bz2
gentoo-94b007ee239c170f0300e790aa9853e0f3df1139.zip
dev-ruby/certificate_authority: add 1.0.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/certificate_authority/Manifest1
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/Manifest b/dev-ruby/certificate_authority/Manifest
index 91e50b16684f..293c08b814e7 100644
--- a/dev-ruby/certificate_authority/Manifest
+++ b/dev-ruby/certificate_authority/Manifest
@@ -1 +1,2 @@
DIST certificate_authority-0.1.6.gem 22528 BLAKE2B 85b229c7506b787b85b734883967dd8e6fc4ceece57dec2b2b8c29fffbaec2d95931af5412d61ef9935e547b68b14213e5cc6971f94ad6294476cc653684742b SHA512 d1471171aa01956ca216bdb8515e9f6fafc9720827e7351b14c7c38907e87b66a3299d9ee0322fb51b8edd1cbc4f4a73a2aa4b54ff5ca4c8bc602ced5e035a59
+DIST certificate_authority-1.0.0.tar.gz 57104 BLAKE2B e585b19b6740349e520e021d4981c3941bca9e6c9b11867c9484e98b4e74e4ebafb47c648564c3e8b89e3591414a90ee404bab83cafd5a3354354b36b3002436 SHA512 e5f05d3df86ae7e7e6ed8937667b14229cda884996c30d9a39f1ad7db781e58abb3f61c251c21174b4988adf0ecdecb1b0f22ed97ddae071ba12c78379524785
diff --git a/dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild b/dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild
new file mode 100644
index 000000000000..a49df5a8922d
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="certificate_authority.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+SRC_URI="https://github.com/cchandler/certificate_authority/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\|overalls\)/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/spec.files/,/end/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}