summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-25 07:56:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-25 09:12:37 +0200
commit94edb181982ebb327d8b499d33e43f6f66c2bd29 (patch)
treedc7bf596a0d473e0d98073c166d91a656cfc84ea
parentdev-python/tomlkit: Bump to 0.11.0 (diff)
downloadgentoo-94edb181982ebb327d8b499d33e43f6f66c2bd29.tar.gz
gentoo-94edb181982ebb327d8b499d33e43f6f66c2bd29.tar.bz2
gentoo-94edb181982ebb327d8b499d33e43f6f66c2bd29.zip
dev-python/rich: Bump to 12.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-12.4.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index f7ee6dd905b9..e23332d273df 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -3,3 +3,4 @@ DIST rich-12.3.0.gh.tar.gz 14889665 BLAKE2B baa098e25768b4b84a269547c7726d281f67
DIST rich-12.4.0.gh.tar.gz 14890620 BLAKE2B fe38abeec7f896053fc2f13259694dd90378db5318683243cf7b13add91c356992b9e4faa475aa282af70694b14e7c82e54c292bd3bcb4411d460dc831310b26 SHA512 dec7903854b29d13b31d3b17a592cd6b94ea1fb6626f7d8abae57927e8cd8021a51cf060b0f431d6fd8a358ae6938038f5aad0c695afa121e05ab3e97aa61006
DIST rich-12.4.1.gh.tar.gz 14890981 BLAKE2B 7eb8424ca5e3a985e6d000ed2c74784dba104237a67315c59d3f3cdf71a7196621566b9f40f7ca0e9f74d6bcd1daae781ee2aef871f5fbf738d3209ae13dba4a SHA512 ee02526c5e717976c2b4a8e750dc9f87d5b2d15a9b144aabb8e84de01ba4df78985ad5ed6bbcf9f6e42a76a63cab6da76c05da917aa8c09d678858fa148db76c
DIST rich-12.4.3.gh.tar.gz 14891108 BLAKE2B 39dc5a1104611bff1b15d29f244126fe1bb76862470d28563cc4cd2868357a259f5986405f2142f6710d70fdc1a759dcb0e46f49ec8e7d3107fb6d6b7c51feba SHA512 8ec22a81014abf2511de72009b7673047dd010ece8a46a733ea05f4b7ca7855723f400556834e41dbbd76c4fcdd5132a74f806f669bb1f1f4d4db71e55ae9cae
+DIST rich-12.4.4.gh.tar.gz 14891341 BLAKE2B 7829951edb77b8e78bcbdeb340fa6c96901d634fb59ab16b8866b898973a95bd38de9dd1a8f6c821cd2222447878a5d22773abec329f49753e207b5b358c3532 SHA512 c1d077bb1448fd436fea87697d31b484615f787c9259418d6ebd12da45bf14f25f192198e4522653c5bd4e5ba218da7d72597e20d04dbffce4a3ea8bd82ce27c
diff --git a/dev-python/rich/rich-12.4.4.ebuild b/dev-python/rich/rich-12.4.4.ebuild
new file mode 100644
index 000000000000..a049e4167d88
--- /dev/null
+++ b/dev-python/rich/rich-12.4.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # broken with =dev-python/pygments-2.12.0
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # the usual deal: output changes that cause test mismatches
+ tests/test_inspect.py::test_inspect_text
+ tests/test_inspect.py::test_inspect_builtin_function
+ tests/test_inspect.py::test_inspect_integer_with_methods
+ tests/test_log.py::test_log
+ tests/test_pretty.py::test_attrs_broken
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}