summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-20 22:55:02 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-21 00:34:35 +0200
commit953191395f71c76cb817088e968bc109d951d7dc (patch)
tree6067daafc72daeb838d8ffe8ad9a891b690a5647
parentsys-devel/llvm-common: Bump -9999 to EAPI 7 (diff)
downloadgentoo-953191395f71c76cb817088e968bc109d951d7dc.tar.gz
gentoo-953191395f71c76cb817088e968bc109d951d7dc.tar.bz2
gentoo-953191395f71c76cb817088e968bc109d951d7dc.zip
sys-devel/llvm: Bump -9999 to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 556b4d9e54d..90b0e0d3850 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
# (needed due to CMAKE_BUILD_TYPE != Gentoo)
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
- multiprocessing pax-utils python-any-r1 toolchain-funcs
+inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -69,7 +69,6 @@ DEPEND="${RDEPEND}
dev-python/recommonmark[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
') )
- !doc? ( ${PYTHON_DEPS} )
gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
@@ -259,15 +258,15 @@ src_install() {
multilib-minimal_src_install
# move wrapped headers back
- mv "${ED%/}"/usr/include "${ED%/}"/usr/lib/llvm/${SLOT}/include || die
+ mv "${ED}"/usr/include "${ED}"/usr/lib/llvm/${SLOT}/include || die
}
multilib_src_install() {
cmake-utils_src_install
# move headers to /usr/include for wrapping
- rm -rf "${ED%/}"/usr/include || die
- mv "${ED%/}"/usr/lib/llvm/${SLOT}/include "${ED%/}"/usr/include || die
+ rm -rf "${ED}"/usr/include || die
+ mv "${ED}"/usr/lib/llvm/${SLOT}/include "${ED}"/usr/include || die
LLVM_LDPATHS+=( "${EPREFIX}/usr/lib/llvm/${SLOT}/$(get_libdir)" )
}
@@ -287,7 +286,7 @@ multilib_src_install_all() {
pkg_postinst() {
elog "You can find additional opt-viewer utility scripts in:"
- elog " ${EROOT%/}/usr/lib/llvm/${SLOT}/share/opt-viewer"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/opt-viewer"
elog "To use these scripts, you will need Python along with the following"
elog "packages:"
elog " dev-python/pygments (for opt-viewer)"