summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 23:21:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-25 00:01:34 +0100
commit9538f2dfaa10fa9bc7015380e3bbb5defde3deef (patch)
treecdb2cb0f68f5622fb975397be9157d52ef12c289
parentmedia-gfx/fontforge: skip gdk_init if running a script (diff)
downloadgentoo-9538f2dfaa10fa9bc7015380e3bbb5defde3deef.tar.gz
gentoo-9538f2dfaa10fa9bc7015380e3bbb5defde3deef.tar.bz2
gentoo-9538f2dfaa10fa9bc7015380e3bbb5defde3deef.zip
kde-misc/plasma-redshift-control: EAPI-7 bump, fix with redshift-1.12
Systray icon scrollwheel adjustment only worked in one direction without -P param. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-fix-custom-icc-profiles.patch39
-rw-r--r--kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-reset-gamma-ramps.patch25
-rw-r--r--kde-misc/plasma-redshift-control/plasma-redshift-control-1.0.18-r1.ebuild27
3 files changed, 91 insertions, 0 deletions
diff --git a/kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-fix-custom-icc-profiles.patch b/kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-fix-custom-icc-profiles.patch
new file mode 100644
index 000000000000..28a1cc00cf0d
--- /dev/null
+++ b/kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-fix-custom-icc-profiles.patch
@@ -0,0 +1,39 @@
+From 1e2a920633d7085fc4e48f1163f434525b777c5b Mon Sep 17 00:00:00 2001
+From: John Salatas <jsalatas@gmail.com>
+Date: Wed, 6 Mar 2019 14:25:28 -0800
+Subject: Preserve screen colour doesn't work as expected
+
+Summary:
+using a custom .icc profile, running redshift from a command line works good but the applet seems to mess with it, the preserve option doesn't work, either in randr mode or vidmode the .icc is ignored even if it is running in daytime.
+
+See also:
+https://github.com/kotelnik/plasma-applet-redshift-control/issues/54
+
+Reviewers: #Plasma, martinkostolny, broulik
+
+Reviewed By: broulik
+
+Subscribers: broulik, plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D17249
+---
+ package/contents/ui/main.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/package/contents/ui/main.qml b/package/contents/ui/main.qml
+index 2ea8fd3..268cb33 100644
+--- a/package/contents/ui/main.qml
++++ b/package/contents/ui/main.qml
+@@ -96,7 +96,7 @@ Item {
+
+ function stopRedshift() {
+ print('disabling redshift')
+- redshiftDS.connectedSources.length = 0
++ redshiftDS.removeSource(redshiftCommand)
+ redshiftDS.connectedSources.push(redshiftDS.redshiftStopSource)
+ active = false
+ }
+--
+cgit v1.1
diff --git a/kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-reset-gamma-ramps.patch b/kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-reset-gamma-ramps.patch
new file mode 100644
index 000000000000..5e2b36822137
--- /dev/null
+++ b/kde-misc/plasma-redshift-control/files/plasma-redshift-control-1.0.18-reset-gamma-ramps.patch
@@ -0,0 +1,25 @@
+From a26a425145120b8e7782d0225e146fcef7b0640f Mon Sep 17 00:00:00 2001
+From: grmat <grmat@sub.red>
+Date: Wed, 20 Jun 2018 10:14:40 +0200
+Subject: [PATCH] add -P switch to one-shot redshift call
+
+---
+ package/contents/ui/main.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/package/contents/ui/main.qml b/package/contents/ui/main.qml
+index 2ea8fd3..38d7b8a 100644
+--- a/package/contents/ui/main.qml
++++ b/package/contents/ui/main.qml
+@@ -67,7 +67,7 @@ Item {
+ // - commands
+ property string redshiftCommand: 'redshift' + locationCmdPart + modeCmdPart + ' -t ' + dayTemperature + ':' + nightTemperature + brightnessAndGamma + (smoothTransitions ? '' : ' -r')
+ property string redshiftOneTimeBrightnessAndGamma: ' -b ' + (currentBrightness*0.01).toFixed(2) + ':' + (currentBrightness*0.01).toFixed(2) + ' -g ' + gammaR + ':' + gammaG + ':' + gammaB
+- property string redshiftOneTimeCommand: 'redshift -O ' + manualTemperature + redshiftOneTimeBrightnessAndGamma + ' -r'
++ property string redshiftOneTimeCommand: 'redshift -PO ' + manualTemperature + redshiftOneTimeBrightnessAndGamma + ' -r'
+ property string redshiftPrintCommand: 'LANG=C ' + redshiftCommand + ' -p'
+
+ property bool inTray: (plasmoid.parent === null || plasmoid.parent.objectName === 'taskItemContainer')
+--
+2.17.1
+
diff --git a/kde-misc/plasma-redshift-control/plasma-redshift-control-1.0.18-r1.ebuild b/kde-misc/plasma-redshift-control/plasma-redshift-control-1.0.18-r1.ebuild
new file mode 100644
index 000000000000..86113c457810
--- /dev/null
+++ b/kde-misc/plasma-redshift-control/plasma-redshift-control-1.0.18-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="plasma-applet-redshift-control"
+inherit kde5
+
+DESCRIPTION="Plasma 5 applet for controlling redshift"
+HOMEPAGE="https://store.kde.org/p/998916/"
+SRC_URI="https://github.com/kotelnik/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="$(add_frameworks_dep plasma)"
+RDEPEND="${DEPEND}
+ x11-misc/redshift
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-custom-icc-profiles.patch"
+ "${FILESDIR}/${P}-reset-gamma-ramps.patch"
+)