summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-08-27 13:55:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-08-27 13:55:34 -0500
commit95482de51e123784224824b71bab8279013aa33b (patch)
tree99c6a9605232d69c13ec95884f590fd4587a30db
parentapp-admin/puppet: 6.18.0 bump (diff)
downloadgentoo-95482de51e123784224824b71bab8279013aa33b.tar.gz
gentoo-95482de51e123784224824b71bab8279013aa33b.tar.bz2
gentoo-95482de51e123784224824b71bab8279013aa33b.zip
app-admin/puppet-agent: 6.18.0 bump
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.18.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 503fd46be7e0..dd227d930d83 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -4,3 +4,4 @@ DIST puppet-agent_6.16.0-1focal_amd64.deb 22255252 BLAKE2B 64690ea444c666476864f
DIST puppet-agent_6.16.0-1stretch_amd64.deb 22336186 BLAKE2B 2bb62f25bf243e03288a5ee769c37c53c5f1c8f63a5e1a9d231b522409a68f3b3d957adbde0a99f616cdb60ced58cc6de990ff96f2b99d17be4aacd786c460a4 SHA512 dd5536e5fe9caad2dd7da8cfb6e2e2e93138b76f5a1014999f221c2bfcac94f0faecc3035ce09fc170dbb61226325ec82aafd80f1016e1d1ccacad9f1ae1b176
DIST puppet-agent_6.16.0-1stretch_i386.deb 22579590 BLAKE2B e923847d2d381d6a1a9c1761259c72c4c92e34d4aad5643eeadbef38d48a09a95d15fd359ded3501257057dbb892bc4dc5ae60abdc01d646cd194d1b40defd6d SHA512 4015da5a4df08e03ab3bf988fd2afb67c37fa7c820f73793ebc3270364928a6f89a5ebcadfeab1f07d4e88a98ee95c2069e47fde4391d2dea98855a9743b6adb
DIST puppet-agent_6.17.0-1focal_amd64.deb 22317432 BLAKE2B 570ef37c8e170ab1d615782322c895b0eba3193ac51dd221a8f9597c34c923c36874a5add1cf1074160c86dd4c4acc3ff1b65709cee2c0cddd84abe57c300faf SHA512 541010d896c891040154b22eed3f2e39b026cfef5669c95016ba1aa5b919002fcf2b8d2a15cde8efd104fc2e0699a8cb5cc3914bc039a27280f97f7f67d7b153
+DIST puppet-agent_6.18.0-1focal_amd64.deb 22258752 BLAKE2B 547d06b16b2c95ec9be72bd82e1aa0a4a4b511075da73f29ebecdef32ca4ed9b965a38a7c071d9bcc8c444b6974159df97f020878c0e4a20d1f50ff23d4c1129 SHA512 00f0cfd96176f5311f0bab14016ab88da03ecc10fd9e2bf28fc2d9a399600c56a97e23095694be5382005fef0df1c4fe3ff0d1aec3a46d85f74c729a3c62476a
diff --git a/app-admin/puppet-agent/puppet-agent-6.18.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.18.0.ebuild
new file mode 100644
index 000000000000..d2a6b4ff967b
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.18.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../../../usr/lib64/xcrypt/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}