summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-23 16:23:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-23 16:23:09 +0200
commit957db0b234d928bb48a8890f78b2bd6332ebc8f8 (patch)
tree4f5115f1f81d83f78207de90733e07e6602e636d
parentmedia-libs/zimg: bump to 2.5.1 (diff)
downloadgentoo-957db0b234d928bb48a8890f78b2bd6332ebc8f8.tar.gz
gentoo-957db0b234d928bb48a8890f78b2bd6332ebc8f8.tar.bz2
gentoo-957db0b234d928bb48a8890f78b2bd6332ebc8f8.zip
media-libs/x264: Add altivec useflag and disable ppc asm if not enabled, since ppc asm is what that means.
Bug #616004. Patch by Marcus Comstedt Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--media-libs/x264/x264-0.0.20160712.ebuild4
-rw-r--r--media-libs/x264/x264-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/x264/x264-0.0.20160712.ebuild b/media-libs/x264/x264-0.0.20160712.ebuild
index 859892752858..ee2a5490d74c 100644
--- a/media-libs/x264/x264-0.0.20160712.ebuild
+++ b/media-libs/x264/x264-0.0.20160712.ebuild
@@ -22,7 +22,7 @@ SONAME="148"
SLOT="0/${SONAME}"
LICENSE="GPL-2"
-IUSE="10bit +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+IUSE="10bit altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="abi_x86_32? ( ${ASM_DEP} )
@@ -38,7 +38,7 @@ multilib_src_configure() {
tc-export CC
local asm_conf=""
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]]; then
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
asm_conf=" --disable-asm"
fi
diff --git a/media-libs/x264/x264-9999.ebuild b/media-libs/x264/x264-9999.ebuild
index ad54c5cdf91b..8cfe28afdd71 100644
--- a/media-libs/x264/x264-9999.ebuild
+++ b/media-libs/x264/x264-9999.ebuild
@@ -22,7 +22,7 @@ SONAME="148"
SLOT="0/${SONAME}"
LICENSE="GPL-2"
-IUSE="10bit +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+IUSE="10bit altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="abi_x86_32? ( ${ASM_DEP} )
@@ -38,7 +38,7 @@ multilib_src_configure() {
tc-export CC
local asm_conf=""
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]]; then
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
asm_conf=" --disable-asm"
fi