summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-28 10:18:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-28 10:28:55 +0100
commit960d2dc4df1262e7a1b7590a0ebae6fdadcedbcf (patch)
tree0737629081bcea1bfb025e175bfe2cd6d3af4c23
parentnet-libs/nghttp2: Bump to version 1.31.0 (diff)
downloadgentoo-960d2dc4.tar.gz
gentoo-960d2dc4.tar.bz2
gentoo-960d2dc4.zip
sys-libs/tevent: Bump to version 0.9.36
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.9.36.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 675d6b8f7f6a..c79d44fd0ace 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -4,3 +4,4 @@ DIST tevent-0.9.32.tar.gz 590314 BLAKE2B 6159d2eac6ea49814fa83b982176db58fad6a9b
DIST tevent-0.9.33.tar.gz 590611 BLAKE2B 087cd196b5cd0ca675280ce35d2a3f51a69d3e36f3ca99be0860873b0078fa4b94092731e2d23c15e8ad0db9703735ee07b90a1900e27245295f11edb3798e6d SHA512 3a437957859a556e06f24334301c41a3db1433c1e90d651fa74585a638a36d71369f235a8ab51aa0dd8f9d9bb88ad42f2c3ddeba0b99c4234c63866a8c922b91
DIST tevent-0.9.34.tar.gz 590260 BLAKE2B 7acd5b5ec540ab97641729e2b6300335a581d70ae2a76d0a93959c47cf84109cb1f52234b7189ecdd28390205b828296bbbde0820e9ba23a7bb33677b347a584 SHA512 29ff88cedc05d9345749ee241f8ab083fc6f98d3975b2739629a3a75a766db6ec42133eeb6c9297315ee0c68ab512c70b8b927d2df5ea61880c673ef33b44183
DIST tevent-0.9.35.tar.gz 591546 BLAKE2B d0df81dc1998ae5806f3f8b613c5640af56d52c0e6fdea8f57c95cf4ef5d8bf349992582b97da94cbcc048bc3f758ecb03e836847467588e7dbfbb1aef87b906 SHA512 935719382469a0f39764a7ebdbc0ee977ccca2fc55ff1e896ddd95ba2d065d989f0c366cb98be95ce87475e628b0de38b7138261717a5c2cee870e98339ed5fd
+DIST tevent-0.9.36.tar.gz 592439 BLAKE2B b24dc37aaeb3bc08eb642c85cf34e4fbcf35fbc38421d3f5c3f03fe77ea8252e7a54a956a9c6750c78dcbb11a092e894bd24ea700acdd634edada1f930a67756 SHA512 bca9db9bcf142ba68b207180d19414dddb89a069a4f040383069c8af0df5bb184ca219293c4a1e7b0bc241b9a1ea3d414f8284278ad3a5f0383b9e432450167b
diff --git a/sys-libs/tevent/tevent-0.9.36.ebuild b/sys-libs/tevent/tevent-0.9.36.ebuild
new file mode 100644
index 000000000000..c2a8eb8ad787
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.36.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="https://tevent.samba.org/"
+SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.11[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+#PATCHES=(
+# "${FILESDIR}"/talloc-disable-python.patch
+#)
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}