summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-12 09:25:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-12 10:23:28 +0200
commit974860e38940a1c265cfa741e85af95a6628ff42 (patch)
tree8c00a1f3685d68229ed8ec4192872733d6d07f64
parentx11-misc/rofi: sync live ebuild with latest non-live ebuild (diff)
downloadgentoo-974860e38940a1c265cfa741e85af95a6628ff42.tar.gz
gentoo-974860e38940a1c265cfa741e85af95a6628ff42.tar.bz2
gentoo-974860e38940a1c265cfa741e85af95a6628ff42.zip
dev-python/rq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.9.0.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 39dbceebd319..23ae4a531bfc 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
DIST rq-1.10.tar.gz 598643 BLAKE2B 503c2e45d134434373eb89ce205dc1a82f16e0281c1f872046d51538b3352b0ffeeef72f64991d093f271c276c1a8a3be92fdda4d7db3e083549f69ea7a04560 SHA512 7e2de3e36309eb3c095d34c28d9cba340d0699b8b4b457491d12420bfc1370e0336dc10f4f1115e83ac0ea8884500750895417f8b5c2090105d3c9e32d1b5bec
-DIST rq-1.9.0.tar.gz 592217 BLAKE2B 831fbc7a3fe23ead59041e2556d37e4aa885a21bffa9aeeb0765382e84b56a2ee6d34a864cb03a9a12274c8ac80b714f10a7752d0bae7a79b8e2e7149be4aea7 SHA512 a2ec7b05fe1dda983cfb30182401c6e5367c54b7649ddcb1d3c6d0f0a5f6583665b39ed7c1cb6bc37d067926f089e3fd80ea7558856233edc1bca8234aa728aa
diff --git a/dev-python/rq/rq-1.9.0.ebuild b/dev-python/rq/rq-1.9.0.ebuild
deleted file mode 100644
index 2e4b2930dc94..000000000000
--- a/dev-python/rq/rq-1.9.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
-SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}