summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-28 22:03:06 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-28 22:03:21 +0100
commit975fdb0e4a2cb60729540035e4e4731ab34eb7cc (patch)
tree267f369c8c52442dc18158addfef7e3aacb33cbf
parentnet-p2p/deluge: change shebang to #!/sbin/openrc-run (diff)
downloadgentoo-975fdb0e4a2cb60729540035e4e4731ab34eb7cc.tar.gz
gentoo-975fdb0e4a2cb60729540035e4e4731ab34eb7cc.tar.bz2
gentoo-975fdb0e4a2cb60729540035e4e4731ab34eb7cc.zip
dev-libs/libtommath: Bump #575848
Package-Manager: portage-2.2.27
-rw-r--r--dev-libs/libtommath/Manifest1
-rw-r--r--dev-libs/libtommath/libtommath-1.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/libtommath/Manifest b/dev-libs/libtommath/Manifest
index 741f0885a748..f5c3d88d886d 100644
--- a/dev-libs/libtommath/Manifest
+++ b/dev-libs/libtommath/Manifest
@@ -1 +1,2 @@
DIST libtommath-0.42.0.tar.gz 1732144 SHA256 5246356ba18c1b6edf4a7bc836a3d223842b86914cdba6dd8c112bfc59e227c8 SHA512 d26e7737e5750530a7b96432502f0d458931e67af528872c46ad8dfc921b8f6ef4b3e05cb07d22bd13a8b24db65812928ae4c381250a4df95f6ca55efc3dae23 WHIRLPOOL beab5007a204042fd0a5b86ccc639ee37d82bb4afe2ceebcfe062deffaa259c8a699c81a52e804c2a79cb36914d805c81826a6e456523f729063240d1bfca9e6
+DIST libtommath-1.0.tar.gz 643248 SHA256 5a0d4f9a72dfbacb05cb5dbc545cffe58b08c103506de68b278dc76d05cfe010 SHA512 2744caa886d179a23a96b51dbf0c9090a7a4e923bb4b9c22d3e92fde73e11222861806018f565f3d5425d2ba31b9bb9e1dbf098bfc37d1fd26d33ceb81a8657e WHIRLPOOL 4830fb5a1802908652e4d4629cc205a55a267d60400041685f3c13fb03d2aff5b3e7f9a0b99e7813aaebf6cb41399c9a373de6296514215ac2fdfde90531d5ce
diff --git a/dev-libs/libtommath/libtommath-1.0.ebuild b/dev-libs/libtommath/libtommath-1.0.ebuild
new file mode 100644
index 000000000000..544a4c678252
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
+HOMEPAGE="https://github.com/libtom/libtommath"
+SRC_URI="https://github.com/libtom/libtommath/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+
+src_prepare() {
+ # need libtool for cross compilation. Bug #376643
+ cat <<-EOF > configure.ac
+ AC_INIT(libtommath, 0)
+ AM_INIT_AUTOMAKE
+ LT_INIT
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ touch NEWS README AUTHORS ChangeLog Makefile.am
+ eautoreconf
+ export LT="${S}"/libtool
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+_emake() {
+ emake CC="$(tc-getCC)" -f makefile.shared \
+ IGNORE_SPEED=1 \
+ LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
+ INCPATH="${EPREFIX}/usr/include" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install
+ # We only link against -lc, so drop the .la file.
+ find "${ED}" -name '*.la' -delete
+
+ dodoc changes.txt
+
+ use doc && dodoc *.pdf
+
+ if use examples ; then
+ docinto demo
+ dodoc demo/*.c
+ fi
+}