summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-08-31 21:27:17 +0200
committerSam James <sam@gentoo.org>2020-09-02 20:40:06 +0000
commit97cf65fd933a09edc3bd7282c4d8f10ab27fb227 (patch)
tree593de5b8a3139f89c2e7a917716ebc9707bd56bb
parentsys-apps/dstat: fix test failure (diff)
downloadgentoo-97cf65fd.tar.gz
gentoo-97cf65fd.tar.bz2
gentoo-97cf65fd.zip
net-dialup/freeradius-client: respect AR
Closes: https://bugs.gentoo.org/730388 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Closes: https://github.com/gentoo/gentoo/pull/17351 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-dialup/freeradius-client/files/freeradius-client-1.1.7-ar-configure.in.patch10
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild14
2 files changed, 16 insertions, 8 deletions
diff --git a/net-dialup/freeradius-client/files/freeradius-client-1.1.7-ar-configure.in.patch b/net-dialup/freeradius-client/files/freeradius-client-1.1.7-ar-configure.in.patch
new file mode 100644
index 000000000000..07d477bcc901
--- /dev/null
+++ b/net-dialup/freeradius-client/files/freeradius-client-1.1.7-ar-configure.in.patch
@@ -0,0 +1,10 @@
+--- a/configure.in 2020-07-08 19:20:38.180447370 +0200
++++ b/configure.in 2020-07-08 19:21:00.840479965 +0200
+@@ -33,6 +33,6 @@
+
+ dnl Needed for normal compile
+-AC_PATH_PROG(AR, ar)
++AM_PROG_AR
+ AM_PROG_LIBTOOL
+
+ dnl HAVE_SHADOW_PASSWORDS
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
index 0b182155d465..564fb5f2205d 100644
--- a/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools
DESCRIPTION="FreeRADIUS Client framework"
HOMEPAGE="https://wiki.freeradius.org/project/Radiusclient"
@@ -23,27 +23,25 @@ DOCS=(
README.{radexample,rst}
)
+PATCHES=(
+ "${FILESDIR}/${P}-ar-configure.in.patch"
+)
+
src_prepare() {
default
mv configure.in configure.ac || die \
"Renaming configure.in to configure.ac failed"
+
eautoreconf
}
src_configure() {
- tc-export AR
-
local myeconfargs=(
$(use_enable scp)
$(use_enable shadow)
--with-secure-path
)
econf "${myeconfargs[@]}"
-
- for MAKEFILE in $(find -name Makefile) libtool; do
- sed -i "s|/usr/bin/ar|${AR}|" "${MAKEFILE}" || \
- die "Patching ${MAKEFILE} for ${AR} failed"
- done
}
src_install() {