summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-01-18 09:00:58 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-01-18 09:00:58 +0100
commit985ebf8de327e91ebb967c73862bdd96516660c3 (patch)
tree41ebd67ab4989eaae674df6d5252304323a85300
parentdev-ruby/rubygems: add 3.2.5 (diff)
downloadgentoo-985ebf8de327e91ebb967c73862bdd96516660c3.tar.gz
gentoo-985ebf8de327e91ebb967c73862bdd96516660c3.tar.bz2
gentoo-985ebf8de327e91ebb967c73862bdd96516660c3.zip
sys-kernel/git-sources: Automated version bump to 5.11_rc4.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.11_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 25a0d245a18a..a8fa65b73f97 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.10.tar.xz 116606704 BLAKE2B b923d7b66309224f42f35f8a5fa219421b0a936
DIST patch-5.11-rc1.patch 74495974 BLAKE2B a8a7cae289cb1421597f9c69f07624259a828374de469c120e6c0c3b6857b3242012150fd70d982a994c99d04265ee0f3cf4a2e1c53e00e88b8a4c3a8c77b005 SHA512 4d582b28903a6b529a59b45f18d8b426090d876f90829a4560b07afd72cca9f3160413882d6168f9bcad3273a478b09b9a8dfe746ec9d4ab8cf42f4a7563c2fd
DIST patch-5.11-rc2.patch 74560270 BLAKE2B 1e4ac4ce26e20aa6b48c88af114f6303c6d89ce28b64eb98085ac24a2c7747e706ec988cc5dcaf2fa46f9589a66d721d7808ed39e52da3fffa6f24e2fa01df86 SHA512 a4b0145be9066e9602efe8fc7b6f57f71832b31d4dda9ae4368d0ff95aaf9fec7a238d6c2b1e91c31a4b88feabf41118513891384181043b91cda1211a40fad8
DIST patch-5.11-rc3.patch 75045235 BLAKE2B d159e9e4bedcf6838e0b81462b53445955e59edd266e25cd001d163af36ad56de06dae5496e14663db860805825402959189ce15a80bdb561134d78ff5616b5d SHA512 5fd19e81144ebf489d5a6833b95a21f94c8b0f8d66e85d1c94acdeba008f8705367e03c411c80a61c4c0df30ddfbadcb65ba835014dad6e79c130b756fe518df
+DIST patch-5.11-rc4.patch 75392493 BLAKE2B efc6b837641883d1ed7e165d5ba08a36ec85c3bfce49f4f8a0ed09d39df6ecf5844908c13a0bd2792c3dd2a57073dae211934f681482d3a04c0a3589a0776f68 SHA512 072cca3d9bc343b791278258102186646fb46f4808680c71cbe55ba3574448711aaa85b34e8f664a354d69d1665759c196ed37e23f1c0285851b0d2538ff173d
diff --git a/sys-kernel/git-sources/git-sources-5.11_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.11_rc4.ebuild
new file mode 100644
index 000000000000..d3797acbcee8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.11_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.10"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}