summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-05 23:25:43 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-05 23:26:46 -0700
commit98638617d385a64971fd97873175813209298599 (patch)
treee84617e9b0c0c8176c865c6ff6d6edde7f6ed1d3
parentmedia-gfx/gthumb: Version bump to 3.12.2 (diff)
downloadgentoo-98638617d385a64971fd97873175813209298599.tar.gz
gentoo-98638617d385a64971fd97873175813209298599.tar.bz2
gentoo-98638617d385a64971fd97873175813209298599.zip
gnome-extra/sushi: Version bump to 41.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/sushi/Manifest1
-rw-r--r--gnome-extra/sushi/sushi-41.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index a31edf5147c6..90d5b878c6af 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,2 +1,3 @@
DIST sushi-41.0.tar.xz 80940 BLAKE2B 211fb0c96ac0a911809007ed2e79659cc90a32be23d61137d85cc4502beb995d2131f62bbbb9a66f8da9328a4bf7d83b0c05f93e8913c8390be5cf22baaaeb00 SHA512 690018b846b23b3b21db244ae6e1f373870cc8cdb374dee2f4ba7eebf65af5d33a3366d37476b5f4556daf196c3f9cf8bf44903193831340f23ad33eef3ed484
DIST sushi-41.1.tar.xz 81228 BLAKE2B 8bff3ed2b70be8335139499fb982efc89163ab1ec95ff9053a117a72945d8733f0125ec4c64b7d175212a9d74f36212319e75f46e84b1eda90896a0ea4b26be7 SHA512 55fca36e73842943bb54a2e1ae005ffe0818763e787e1f987479b71527ce36970aa502c22053195fc3711b8cfcbb6892d3f1add674e425b9358d3682972026d5
+DIST sushi-41.2.tar.xz 81252 BLAKE2B 811b02e0738aa3aba22d71545e888ec0334779591a56d6a28f3942d5d79fb9fece2fdffe0203757ba0806352584a50228b669fc0969f7ad75265fc40a3a1cd67 SHA512 c47b22a013fe31de6943d8af0f333b8050a8f0ecb0e827ea71666cd0175d5cc99336eb7ad96b21ba7aaf87f23d01b4f37a1ca8c0fc644fa89aa8960699b61f43
diff --git a/gnome-extra/sushi/sushi-41.2.ebuild b/gnome-extra/sushi/sushi-41.2.ebuild
new file mode 100644
index 000000000000..a9e7cb992539
--- /dev/null
+++ b/gnome-extra/sushi/sushi-41.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="office wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+# Optional app-office/libreoffice support (OOo to pdf and then preview)
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ >=net-libs/webkit-gtk-2.34:4[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+ office? ( app-office/libreoffice )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_feature wayland) \
+ $(meson_feature X X11)
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}