summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-03-08 12:22:00 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-03-08 12:27:31 +0100
commit9869d748199f7fad1746a27248990e10436df568 (patch)
treec3e75577dddb228061413149b98af65505739381
parentx11-plugins/wmbio: fix build with -fno-common (diff)
downloadgentoo-9869d748199f7fad1746a27248990e10436df568.tar.gz
gentoo-9869d748199f7fad1746a27248990e10436df568.tar.bz2
gentoo-9869d748199f7fad1746a27248990e10436df568.zip
x11-plugins/wmmon+smp: fix build with -fno-common
Closes: https://bugs.gentoo.org/707216 Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmmon+smp/files/wmmon+smp-1.0-fno-common.patch24
-rw-r--r--x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild4
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-plugins/wmmon+smp/files/wmmon+smp-1.0-fno-common.patch b/x11-plugins/wmmon+smp/files/wmmon+smp-1.0-fno-common.patch
new file mode 100644
index 000000000000..6ec3ba03520d
--- /dev/null
+++ b/x11-plugins/wmmon+smp/files/wmmon+smp-1.0-fno-common.patch
@@ -0,0 +1,24 @@
+diff -Naur wmmon.app.orig/wmgeneral/wmgeneral.h wmmon.app/wmgeneral/wmgeneral.h
+--- wmmon.app.orig/wmgeneral/wmgeneral.h 1999-06-07 03:09:36.000000000 +0200
++++ wmmon.app/wmgeneral/wmgeneral.h 2020-03-08 12:20:10.345121264 +0100
+@@ -36,7 +36,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur wmmon.app.orig/wmmon/wmmon.c wmmon.app/wmmon/wmmon.c
+--- wmmon.app.orig/wmmon/wmmon.c 1999-06-07 05:49:45.000000000 +0200
++++ wmmon.app/wmmon/wmmon.c 2020-03-08 12:20:18.657124944 +0100
+@@ -19,6 +19,8 @@
+ int wmmon_mask_width = 64;
+ int wmmon_mask_height = 64;
+
++Display *display;
++
+ void usage(void);
+ void drawstat(int *, int, int, int, int);
+ void wmmon_routine(int, char **);
diff --git a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
index b1e2679d8c7f..e16511eaf5bb 100644
--- a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
+++ b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
@@ -22,7 +22,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/wmmon.app/wmmon"
-PATCHES=( "${FILESDIR}"/${P}-list.patch )
+PATCHES=( "${FILESDIR}"/${P}-list.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
src_prepare() {
tc-export CC