summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2022-01-01 09:50:09 +0100
committerMatt Turner <mattst88@gentoo.org>2022-01-11 12:55:04 -0800
commit98d868c286553238eb2320e14fe6f20bb22536ff (patch)
tree4fc884d82754251d50685f21259a7aecb689644f
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.171 (diff)
downloadgentoo-98d868c286553238eb2320e14fe6f20bb22536ff.tar.gz
gentoo-98d868c286553238eb2320e14fe6f20bb22536ff.tar.bz2
gentoo-98d868c286553238eb2320e14fe6f20bb22536ff.zip
x11-libs/goocanvas: bump to 3.0.0 and EAPI 8
Closes: https://bugs.gentoo.org/783018 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/goocanvas/Manifest1
-rw-r--r--x11-libs/goocanvas/goocanvas-3.0.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/goocanvas/Manifest b/x11-libs/goocanvas/Manifest
index 0ecdfc19ff97..a44ee5b9ad93 100644
--- a/x11-libs/goocanvas/Manifest
+++ b/x11-libs/goocanvas/Manifest
@@ -1 +1,2 @@
DIST goocanvas-2.0.4.tar.xz 584272 BLAKE2B 027ab47c1e9c241f74509001426367e86025ec8ea5901cf64c2014f8c32b83ce60870ca754dd15e8982a7023b77d3856b39dbbbdd636de6da47d361cb15a940e SHA512 e57dfd59d9b9cb64deadfeac193c11a89347c7f0e966377cfb98afcc2b46be13fe05d253a96e63dc7e6981c75e6e871040b83d8d0aee95cb62b79965d6be5688
+DIST goocanvas-3.0.0.tar.xz 556832 BLAKE2B 4ee632a614b6b881000bbee8d5e21a166151a94667c603c92b94c5e076fab78a6df44fe1d45fb4d7c4d65c0e060b599abf3970313542836a63efbca33d6a075b SHA512 a53839af4d98afdfc0f92531bdb09013dd71e964185dc2670af077bb7b41b9ff5c75f2801f6e77c99055b38f3603d8cf197f84affb8d7c3196526ce824b228e3
diff --git a/x11-libs/goocanvas/goocanvas-3.0.0.ebuild b/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
new file mode 100644
index 000000000000..16b18094e850
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/cairo-1.10.0
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.16
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.{am,in} || die "Failed to sed demo"
+
+ # Python bindings are built/installed manually, but not at all anymore (py2).
+ sed -e "/SUBDIRS = python/d" \
+ -i bindings/Makefile.{am,in} || die "Failed to sed python subdirs"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ PYTHON=true gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}