summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-01-28 11:35:30 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-18 09:37:23 +0100
commit998642661d7a005f41b1bf0782d6a7e6659e4503 (patch)
treef6a53c1c9a3570b3ca289316bb339a3b08d4ab9d
parentsys-cluster/teleport: add v2.5.2 (diff)
downloadgentoo-998642661d7a005f41b1bf0782d6a7e6659e4503.tar.gz
gentoo-998642661d7a005f41b1bf0782d6a7e6659e4503.tar.bz2
gentoo-998642661d7a005f41b1bf0782d6a7e6659e4503.zip
games-roguelike/FTL-gog: new package
Closes: https://github.com/gentoo/gentoo/pull/6987 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--games-roguelike/FTL-gog/FTL-gog-1.6.3.ebuild54
-rw-r--r--games-roguelike/FTL-gog/Manifest1
-rw-r--r--games-roguelike/FTL-gog/metadata.xml16
3 files changed, 71 insertions, 0 deletions
diff --git a/games-roguelike/FTL-gog/FTL-gog-1.6.3.ebuild b/games-roguelike/FTL-gog/FTL-gog-1.6.3.ebuild
new file mode 100644
index 000000000000..74c5fc0f33b8
--- /dev/null
+++ b/games-roguelike/FTL-gog/FTL-gog-1.6.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop unpacker
+
+DESCRIPTION="Top-down roguelike space ship simulator"
+HOMEPAGE="https://www.gog.com/game/faster_than_light"
+SRC_URI="ftl_advanced_edition_en_1_6_3_17917.sh"
+RESTRICT="bindist fetch mirror strip test"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="media-libs/freetype
+ media-libs/libsdl[X,sound,opengl,video]
+ media-libs/libpng
+ sys-libs/zlib
+ virtual/opengl"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from"
+ elog "https://www.gog.com/game/faster_than_light"
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${A}"
+}
+
+src_prepare() {
+ default
+ rm -r support/{xdg*,*.{sh,txt}} || die
+ if ! use x86; then
+ rm game/data/FTL.x86 || die
+ fi
+ if ! use amd64; then
+ rm game/data/FTL.amd64 || die
+ fi
+}
+
+src_install() {
+ insinto /opt/gog/FTL
+ doins -r .
+ fperms 755 /opt/gog/FTL/{start.sh,game/{FTL,data/FTL*}}
+
+ make_desktop_entry "/opt/gog/FTL/start.sh" "FTL: Advanced Edition" FTL
+ newicon support/icon.png FTL.png
+}
diff --git a/games-roguelike/FTL-gog/Manifest b/games-roguelike/FTL-gog/Manifest
new file mode 100644
index 000000000000..0833ae5534ba
--- /dev/null
+++ b/games-roguelike/FTL-gog/Manifest
@@ -0,0 +1 @@
+DIST ftl_advanced_edition_en_1_6_3_17917.sh 190333601 BLAKE2B 18fb43da1718524fcdecbde9d9cbfbed84db6e5b3a49abbec9b331d13f9ce7ca807633f3ad126badba9e92278b264ab3de47efabbf772180a35c108ce07268f1 SHA512 6cc3770d9a3d9ac301d79eaee0b88d3d4bbf90186356d443f53d4e894b4cdefd36c080e23506d76e0a3f7e15267e3e206469872cc7b29ddeaa20d520b9dfddd0
diff --git a/games-roguelike/FTL-gog/metadata.xml b/games-roguelike/FTL-gog/metadata.xml
new file mode 100644
index 000000000000..727ed940cf5b
--- /dev/null
+++ b/games-roguelike/FTL-gog/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kitsunenokenja@protonmail.ch</email>
+ <name>Rob Levitsky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>