summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-12 09:46:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-12 19:09:02 +0100
commit998666036e59200210d442094bbfceb07b7b8c8b (patch)
tree1741fcb902d9af0ec40cd31a21cf4da7994def8e
parentsys-kernel/gentoo-sources: Revert ibmvnic: rem dup napi_schedule call (diff)
downloadgentoo-998666036e59200210d442094bbfceb07b7b8c8b.tar.gz
gentoo-998666036e59200210d442094bbfceb07b7b8c8b.tar.bz2
gentoo-998666036e59200210d442094bbfceb07b7b8c8b.zip
app-emulation/wine-staging: backport AR RANLIB handling from wine-vanilla
Before the change binutils-config[-native-symlinks] build failed in attempt to use unprefixed `ar`. The fix is present in wine-vanilla for a while. This change backports it to wine-staging. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21609 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--app-emulation/wine-staging/wine-staging-6.12.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/app-emulation/wine-staging/wine-staging-6.12.ebuild b/app-emulation/wine-staging/wine-staging-6.12.ebuild
index 9f66da3e67f9..77c35e15d933 100644
--- a/app-emulation/wine-staging/wine-staging-6.12.ebuild
+++ b/app-emulation/wine-staging/wine-staging-6.12.ebuild
@@ -528,10 +528,9 @@ multilib_src_configure() {
$(use_with vaapi va)
)
- local PKG_CONFIG AR RANLIB
+ local PKG_CONFIG
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
- # set AR and RANLIB to make QA scripts happy; #483342
- tc-export PKG_CONFIG AR RANLIB
+ tc-export PKG_CONFIG
if use amd64; then
if [[ ${ABI} == amd64 ]]; then
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 5fa927046960..97f1f4176260 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -528,10 +528,9 @@ multilib_src_configure() {
$(use_with vaapi va)
)
- local PKG_CONFIG AR RANLIB
+ local PKG_CONFIG
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
- # set AR and RANLIB to make QA scripts happy; #483342
- tc-export PKG_CONFIG AR RANLIB
+ tc-export PKG_CONFIG
if use amd64; then
if [[ ${ABI} == amd64 ]]; then