summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-21 09:07:44 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-21 09:11:20 +0100
commit99de5149762e8d334cad249aee7bdeaa10730616 (patch)
tree24db08d4ef53990e8435cbee71b3ae99f7dacf23
parentdev-java/commons-discovery: treeclean (diff)
downloadgentoo-99de5149762e8d334cad249aee7bdeaa10730616.tar.gz
gentoo-99de5149762e8d334cad249aee7bdeaa10730616.tar.bz2
gentoo-99de5149762e8d334cad249aee7bdeaa10730616.zip
dev-java/commons-dbutils: treeclean
Closes: https://bugs.gentoo.org/736575 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-java/commons-dbutils/Manifest1
-rw-r--r--dev-java/commons-dbutils/commons-dbutils-1.6.ebuild53
-rw-r--r--dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml263
-rw-r--r--dev-java/commons-dbutils/metadata.xml8
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 326 deletions
diff --git a/dev-java/commons-dbutils/Manifest b/dev-java/commons-dbutils/Manifest
deleted file mode 100644
index 6df2eacae640..000000000000
--- a/dev-java/commons-dbutils/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST commons-dbutils-1.6-src.tar.gz 90708 BLAKE2B 0793d19808d7baf492a80df50976b74354bb88768af71bfa5961de0fa8b7f7b4896962b4cf57b1ab2de912dbdf60c4374e2d2b9445b86c5e934c347bf840cb80 SHA512 05aa5fb448d949ac4d5d34f1219539e57cfb550fa423af0691cb35002984036b0de62b8f618199bd2f562a441867c5b7138e9204afc36bd6d0fa2c4c5e9cd2c6
diff --git a/dev-java/commons-dbutils/commons-dbutils-1.6.ebuild b/dev-java/commons-dbutils/commons-dbutils-1.6.ebuild
deleted file mode 100644
index d50314e58713..000000000000
--- a/dev-java/commons-dbutils/commons-dbutils-1.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A small set of classes designed to make working with JDBC easier"
-HOMEPAGE="http://commons.apache.org/dbutils/"
-SRC_URI="mirror://apache/commons/dbutils/source/${P}-src.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.6
- test? (
- dev-java/mockito:0
- dev-java/ant-junit:0
- dev-java/hamcrest-core:1.3
- )"
-RDEPEND=">=virtual/jre-1.6"
-
-S="${WORKDIR}/${P}-src"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-EANT_TEST_TARGET="test"
-EANT_TEST_GENTOO_CLASSPATH="
- mockito
- hamcrest-core-1.3
-"
-
-# Uses a bunch of deprecated methods.
-JAVA_RM_FILES=(
- src/test/java/org/apache/commons/dbutils/handlers/ArrayHandlerTest.java
-)
-
-java_prepare() {
- cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java
-}
diff --git a/dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml b/dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml
deleted file mode 100644
index 725d4eaca036..000000000000
--- a/dev-java/commons-dbutils/files/commons-dbutils-1.6-build.xml
+++ /dev/null
@@ -1,263 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 10/5/15 8:20 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="commons-dbutils-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-dbutils-1.6"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.build.testResourceDir.1" value="."/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
- <pathelement location="${maven.repo.local}/org/mockito/mockito-core/1.9.5/mockito-core-1.9.5.jar"/>
- <pathelement location="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-all/1.3/hamcrest-all-1.3.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
- <copy todir="${maven.build.testOutputDir}/META-INF">
- <fileset dir="${maven.build.testResourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/TestBean.java"/>
- <exclude name="**/BaseTestCase.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/BaseTestCase.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="iso-8859-1"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- docencoding="iso-8859-1"
- source="1.6"
- linksource="true"
- breakiterator="false">
- <link href="http://docs.oracle.com/javase/6/docs/api/"/>
- <link href="http://docs.oracle.com/javaee/6/api/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class" value="Main"/>
- </manifest>
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
-</project>
diff --git a/dev-java/commons-dbutils/metadata.xml b/dev-java/commons-dbutils/metadata.xml
deleted file mode 100644
index 6ef2d50cf07e..000000000000
--- a/dev-java/commons-dbutils/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 7d9f9c419ec6..d7d9fa52256e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -386,7 +386,6 @@ dev-java/blowfishj
dev-java/btf
dev-java/commons-chain
dev-java/commons-dbcp
-dev-java/commons-dbutils
# Sergey Popov <pinkbyte@gentoo.org> (2021-10-22)
# Upstream support discontinued, see https://bw.org/2019/03/19/bw-whois/