summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-03 08:39:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 12:24:07 +0200
commit99e617111d03109a0b78274807dfc070ffcc6eef (patch)
treec60148c46877f321f1bca69e9e8088201a29e3da
parentsys-auth/rtkit: stable 0.12-r1 for sparc, bug #720016 (diff)
downloadgentoo-99e617111d03109a0b78274807dfc070ffcc6eef.tar.gz
gentoo-99e617111d03109a0b78274807dfc070ffcc6eef.tar.bz2
gentoo-99e617111d03109a0b78274807dfc070ffcc6eef.zip
dev-python/pytest-xdist: Bump to 1.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/files/pytest-xdist-1.32.0-timeout.patch50
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.32.0.ebuild43
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 98896ef5ab86..1b1e4f01f852 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -2,3 +2,4 @@ DIST pytest-xdist-1.23.2.tar.gz 59932 BLAKE2B f2cf73914cf095217fb8b472f5e5f79184
DIST pytest-xdist-1.28.0.tar.gz 61486 BLAKE2B ef8157079ea890342cd566f327588148fa898a3404e3edcffb60ba8ba37d9473b4c2a47fc737f7bb074042c6aadd737ac51f348ce79a718eb446036016cd5e23 SHA512 89b8885103a944ae72535de40028db052f76631ade6f969489d3dc3a1a61a3233df6655d0905d9f5253f23740a15aea824b460c680e79c16f275b31cb2abd6ad
DIST pytest-xdist-1.30.0.tar.gz 62286 BLAKE2B 8d6a79c123bcee81751f2dd3a87e1d8effc82ff48a701c8cf0014292e5df575136d25847794c8e9fc94eb88a37cb42c659a142212faf30b0d1a0b1f9f948d2d6 SHA512 978b67df2366d916db62af21f2c610ac5d2de43cecf3260ec9bf52f904098514c3052ce8ca2195c17addd4012f3c5d38ce8a701d26c8158142a821b0d0cf9122
DIST pytest-xdist-1.31.0.tar.gz 66133 BLAKE2B 79fe5f3bcad3421c1c751ffe6e09f0da42d4ff7c0016cb421ffabcab167028ec41ccfb02bbb275564cd74b13ade8d6e79bbb70b34995f3bc9000604a1533df9a SHA512 b7960d20295232b251c8ddcc5a3b9d6e7b761d577ba11c2647b4b4b410ee5c05998cf57fa57208561eb3ea7c4914db1fd446173794589d8c8e8e79ff8e0ad3aa
+DIST pytest-xdist-1.32.0.tar.gz 67733 BLAKE2B da0ce4e43dc8752e4329ddcbc13a5f55f5bc120c13f39bb01916770d2dc1864197fd91f92bc55ba27cd74b0d837ac2d310980874cdf54761339b2cd654dd6e74 SHA512 f159b4653efb4afeff4124df484670d3c672e1014712f948390b25efc53096f8237258c83a5f1a9e688c52b4a756291cb731d37fdfa800707f556550a19cb0e8
diff --git a/dev-python/pytest-xdist/files/pytest-xdist-1.32.0-timeout.patch b/dev-python/pytest-xdist/files/pytest-xdist-1.32.0-timeout.patch
new file mode 100644
index 000000000000..52fdc681dfb2
--- /dev/null
+++ b/dev-python/pytest-xdist/files/pytest-xdist-1.32.0-timeout.patch
@@ -0,0 +1,50 @@
+From 27519e8018ee199219ab223e0b31b76b4e950a2a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 3 May 2020 11:23:33 +0200
+Subject: [PATCH] Increase pexpect timeouts to prevent tests from failing
+
+---
+ testing/acceptance_test.py | 2 +-
+ testing/test_looponfail.py | 6 ++++--
+ 2 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/testing/acceptance_test.py b/testing/acceptance_test.py
+index b6a4a94..a089baa 100644
+--- a/testing/acceptance_test.py
++++ b/testing/acceptance_test.py
+@@ -332,7 +332,7 @@ class TestDistribution:
+ time.sleep(10)
+ """
+ )
+- child = testdir.spawn_pytest("-n1 -v")
++ child = testdir.spawn_pytest("-n1 -v", expect_timeout=30.0)
+ child.expect(".*test_sleep.*")
+ child.kill(2) # keyboard interrupt
+ child.expect(".*KeyboardInterrupt.*")
+diff --git a/testing/test_looponfail.py b/testing/test_looponfail.py
+index 94fccd7..a6ebebe 100644
+--- a/testing/test_looponfail.py
++++ b/testing/test_looponfail.py
+@@ -284,7 +284,8 @@ class TestFunctional:
+ )
+ # p = testdir.mkdir("sub").join(p1.basename)
+ # p1.move(p)
+- child = testdir.spawn_pytest("-f %s --traceconfig" % p)
++ child = testdir.spawn_pytest("-f %s --traceconfig" % p,
++ expect_timeout=30.0)
+ child.expect("def test_one")
+ child.expect("x == 1")
+ child.expect("1 failed")
+@@ -311,7 +312,8 @@ class TestFunctional:
+ pass
+ """
+ )
+- child = testdir.spawn_pytest("-f %s" % p)
++ child = testdir.spawn_pytest("-f %s" % p,
++ expect_timeout=30.0)
+ child.expect("1 xpass")
+ # child.expect("### LOOPONFAILING ####")
+ child.expect("waiting for changes")
+--
+2.26.2
+
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.32.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.32.0.ebuild
new file mode 100644
index 000000000000..4d03af9b28d5
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.32.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.4[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/pytest-xdist-1.32.0-timeout.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}