summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-04-26 12:25:15 +0100
committerMarek Szuba <marecki@gentoo.org>2018-04-26 12:30:28 +0100
commit9a9cafec65f1eb3de700a077dae30537993823cc (patch)
tree3e4212fd6c27372203cb3b09eccdacd052db9863
parentsys-apps/restorecond: bump to 2.8_rc1 (diff)
downloadgentoo-9a9cafec65f1eb3de700a077dae30537993823cc.tar.gz
gentoo-9a9cafec65f1eb3de700a077dae30537993823cc.tar.bz2
gentoo-9a9cafec65f1eb3de700a077dae30537993823cc.zip
dev-perl/Bio-DB-HTS: new package
Perl bindings for sci-libs/htslib, used by e.g. Ensembl. Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild30
-rw-r--r--dev-perl/Bio-DB-HTS/Manifest1
-rw-r--r--dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch29
-rw-r--r--dev-perl/Bio-DB-HTS/metadata.xml17
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild
new file mode 100644
index 000000000000..02c38cd34f33
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=AVULLO
+DIST_VERSION=2.10
+
+inherit perl-module
+
+DESCRIPTION="Perl bindings for sci-libs/htslib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sci-libs/htslib:="
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-LeakTrace )"
+
+PATCHES=(
+ "${FILESDIR}/2.10-build_search_for_so.patch"
+)
+
+src_configure() {
+ local myconf="--htslib=${EPREFIX}/usr"
+ perl-module_src_configure
+}
diff --git a/dev-perl/Bio-DB-HTS/Manifest b/dev-perl/Bio-DB-HTS/Manifest
new file mode 100644
index 000000000000..536315137fa5
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Manifest
@@ -0,0 +1 @@
+DIST Bio-DB-HTS-2.10.tar.gz 5245650 BLAKE2B a52d9b1e19d5920d61dd365eacfd1a40726500e25a3ab516df5a1d59a7a9d79ce02db7a2145801b6af5df2c41c95e80b49a39db83d27fd7ff3cf88ba0e6a328d SHA512 4e7c01022d9edf48a0e0dcffcbccf34812f236d1b581760ac115c323de5779fb6212eb4ad7d1953811930a6137cc8f5f59028c73d645d1ca5fb6118dd846ad57
diff --git a/dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch b/dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch
new file mode 100644
index 000000000000..b3d11bbbe7aa
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/files/2.10-build_search_for_so.patch
@@ -0,0 +1,29 @@
+--- a/Build.PL
++++ b/Build.PL
+@@ -125,7 +125,7 @@
+
+ my $hts_lib = "$root";
+ my $hts_include = "$root/htslib";
+- if (-f "$hts_lib/libhts.a" && -f "$hts_include/hts.h") {
++ if ((-f "$hts_lib/libhts.so" || -f "$hts_lib/libhts.a") && -f "$hts_include/hts.h") {
+ $self->config_data('hts_lib' => $hts_lib);
+ $self->config_data('hts_include' => $hts_include);
+ return 1;
+@@ -145,7 +145,7 @@
+
+ my $hts_lib = "$root/lib";
+ my $hts_include = "$root/include/htslib";
+- if (-f "$hts_lib/libhts.a" && -f "$hts_include/hts.h") {
++ if ((-f "$hts_lib/libhts.so" || -f "$hts_lib/libhts.a") && -f "$hts_include/hts.h") {
+ $self->config_data('hts_lib' => $hts_lib);
+ $self->config_data('hts_include' => $hts_include);
+ return 1;
+@@ -164,7 +164,7 @@
+ This module requires htslib (http://htslib/org)
+ Install it if you have not done so already.
+
+-This script will attempt to locate htslib by looking for hts.h and libhts.a in:
++This script will attempt to locate htslib by looking for hts.h and libhts.so/libhts.a in:
+
+ 1. --htslib command line argument
+ 2. HTSLIB_DIR environment variable
diff --git a/dev-perl/Bio-DB-HTS/metadata.xml b/dev-perl/Bio-DB-HTS/metadata.xml
new file mode 100644
index 000000000000..95abbb699ad4
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Ensembl/Bio-DB-HTS</remote-id>
+ <remote-id type="cpan">Bio-DB-HTS</remote-id>
+ <remote-id type="cpan-module">Bio::DB::HTS</remote-id>
+ </upstream>
+</pkgmetadata>