summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-01 16:14:16 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:45 -0500
commit9aba4a41331cdc08b09526eb265760aa05e78e38 (patch)
treefbb0d252a6681ac7a43867bef0d0db191ec39367
parentsci-libs/cxsparse: new version 3.2.0. (diff)
downloadgentoo-9aba4a41331cdc08b09526eb265760aa05e78e38.tar.gz
gentoo-9aba4a41331cdc08b09526eb265760aa05e78e38.tar.bz2
gentoo-9aba4a41331cdc08b09526eb265760aa05e78e38.zip
sci-libs/ccolamd: new version 2.9.6.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-libs/ccolamd/Manifest1
-rw-r--r--sci-libs/ccolamd/ccolamd-2.9.6.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/sci-libs/ccolamd/Manifest b/sci-libs/ccolamd/Manifest
index f114cc24c398..5848537395b9 100644
--- a/sci-libs/ccolamd/Manifest
+++ b/sci-libs/ccolamd/Manifest
@@ -1 +1,2 @@
DIST ccolamd-2.8.0.tar.bz2 309907 BLAKE2B 1229d0802a53613d2a320906889dc5ae928bc0b21003d0340f7c5f153a8a7fab8302981c1c2421f64ca5c9f5a1e9460ad5d136a6c1efbc401666f82d7aab1901 SHA512 6a515a8250ed98d52aa932a6f93170174ff32f76c1ecedcedeb1540a471416d0cd40b5613a839b96fbc79c66b3cb5106c6a340a33fafdd695c83b7d949756e77
+DIST ccolamd-2.9.6.tar.bz2 305744 BLAKE2B 0d741ead328a1e888715672ddb617cc96a559f46f2379e1d7792b70868dd290de19b3047e3ed4dd2711084c9afc523d18ecb375aa4ee8a4a12950cee08f238b8 SHA512 cf6f210d26ddb1be454cac377a773b73b75261a74e1e3985565f57f45659b1c11b747829c5bbe99c4bc3e8b364d7b2b3c109e00f6d7e8e41afd713312ebf103c
diff --git a/sci-libs/ccolamd/ccolamd-2.9.6.ebuild b/sci-libs/ccolamd/ccolamd-2.9.6.ebuild
new file mode 100644
index 000000000000..cbeecdadbaf3
--- /dev/null
+++ b/sci-libs/ccolamd/ccolamd-2.9.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Constrained Column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage//${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="sci-libs/suitesparseconfig"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}