summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:53 +0300
commit9ace1f1f26c282a33acb4b446df8ac8275912491 (patch)
tree061493cb9bbb60ceae31665b735127a4667c8f70
parentdev-python/boto3: add 1.24.80 (diff)
downloadgentoo-9ace1f1f26c282a33acb4b446df8ac8275912491.tar.gz
gentoo-9ace1f1f26c282a33acb4b446df8ac8275912491.tar.bz2
gentoo-9ace1f1f26c282a33acb4b446df8ac8275912491.zip
app-admin/awscli: add 1.25.81
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.81.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index e1e6bd973d28..5833e4013732 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -10,3 +10,4 @@ DIST aws-cli-1.25.75.gh.tar.gz 2270365 BLAKE2B 68cd58d03e0712133104dbb145c6d4bce
DIST aws-cli-1.25.76.gh.tar.gz 2270850 BLAKE2B 5c642f9cff01884a7a54c619ff8a174b88209d2010ddec22b99e6d6b8294a3aeaca5b0737c050ab3a1ae339046ef41565669db3a706c0bbf03206ce164784cbf SHA512 43a939c87b1cad66be7c45092ba069933a89aa7ad638bf06d2b7995e59728c1a88971481714f2a950148b3974ac105b3d2f3c6e535f61e0722ff3037a86a9a7c
DIST aws-cli-1.25.79.gh.tar.gz 2272740 BLAKE2B f7b411a17d13ab9e2f19c46827d63d47079b6563dd11fd0ecc200256974e1fb45787bd6f92b90248b406622eca163c5a0ed027a7f20de695699b074178316cbd SHA512 3b7986cb43e0c1124e11a70d6d4bfc932919aef4a40f41bbeed27d19659e0de0c69ef8426078d3b3193bbfe43de07fc7df460898426822ca885d6c3497f7c2d1
DIST aws-cli-1.25.80.gh.tar.gz 2272910 BLAKE2B c7735b405a00a32d67b86bc56cdbbebceaf195ea00ab4250bb6ff091778b67d678a8529bbe8e6ef51a7f0f740a575d2a201dd2cd930c6046247eca469a2b4821 SHA512 10cba4c1e7c562b70d685c185af5dc727128882f5e3ed72dc5ed172b9e201f9b3431bf642f0d556855d5db336e5f7c2ddc0517d414a25e96f6bbfa98cae36f49
+DIST aws-cli-1.25.81.gh.tar.gz 2273195 BLAKE2B 3bf3ca742b08c0bf4367ae1bfabcf8c2626010d60cc11ff66250753f62609eba80053c1d8696cc3184ba9f947f995a8bb95489b01f60a3fa7e1a8cbb4961652c SHA512 4f10de492a56b158d88671c149d4ed4171fbbde8fe84de15a446e31a7d8003a4562439eabd369cb80dcf91987caab6aef05e5b3f5684aeea47ba0d323883c53c
diff --git a/app-admin/awscli/awscli-1.25.81.ebuild b/app-admin/awscli/awscli-1.25.81.ebuild
new file mode 100644
index 000000000000..511be374181c
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.81.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).(z-1)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 1 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}