summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-08-04 01:31:23 +0100
committerSam James <sam@gentoo.org>2021-08-04 22:00:50 +0100
commit9adcd75b7e32918dd234b6cb7314c2ce653f96cc (patch)
tree7192566302e36e48a715ab15e97ee293d2136418
parentmedia-libs/intel-mediasdk: add missing libdrm dep, fix GCC 11 build (diff)
downloadgentoo-9adcd75b7e32918dd234b6cb7314c2ce653f96cc.tar.gz
gentoo-9adcd75b7e32918dd234b6cb7314c2ce653f96cc.tar.bz2
gentoo-9adcd75b7e32918dd234b6cb7314c2ce653f96cc.zip
dev-util/ostree: Version updated to 2021.3.
Closes: https://bugs.gentoo.org/788313 Closes: https://bugs.gentoo.org/801040 Signed-off-by: Jonathan Davies <jpds@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/21873 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/ostree-2021.3.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index 4837fb492747..cb2f4fc7ecdc 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -2,3 +2,4 @@ DIST ostree-2019.5.tar.xz 1972452 BLAKE2B a8b015118855b8b0097f535ac074aeffc599c3
DIST ostree-2020.6.tar.xz 2014456 BLAKE2B 97d84c6838993edfbabb598bce800332ab1c8b22c0431839f7129f2f57afdd71c1b8ea8b8d6c1dc2cbf8d7f6828d624394b5e8c533f7a98eb1b1c3aeedff92cf SHA512 1d8f8ccaa3e543a6f494d3be2a3651ad340846f0c314e003955260b7bd1d8c0421acf102ec2ca6580379c354bf4cfac0940e4e95b724b7aaf9dc8116085aa538
DIST ostree-2020.7.tar.xz 2022004 BLAKE2B 2113117ce8553b7ffcfea17e1cb3a9c697d39b4933b48c30729af72fc833bb00f39e7e3a327efeebaac1df307b1f62ccf16a7772e12ad77737e2219c87623824 SHA512 f42dca3c9e1810c0421ab99588f27c625733b71ef811534b66e0c0c4afafbad5bf475e08feaf87c2f8414c38f127fd344adbb57a4b75001077aedbfe92af3706
DIST ostree-2020.8.tar.xz 2081080 BLAKE2B e856f9642db9fd16e96d6bdc9b3f3be93989458d72258c4586e5a49e67c197d0b7b20cefd0b5a28d77dee986db42ae5584d2894005ede654b8320402aa3af367 SHA512 2523f5742c4472f8e64614bb99edc5aec1a8f8a837b54f67efba9760aefc3385014e1296c9246ac81b361f4588deb4794768a231bf8f338c24a14255ab63da04
+DIST ostree-2021.3.tar.xz 2089804 BLAKE2B 5df33b676173b1ec08ac7592d4ddf8e3bfdcd84df1b3ce19e2f24c85780fed1f210b8adce1baf4ec87869c72984502276bf6e5a72268daaae6ce9b3d6dc6f88b SHA512 0df0d8f9bd82b16562dd5146997eddfb7cb6cffc1886601307d97a1cb1dc926bda7d0c899db26c974ed0dff1012dee11937e47c11c4d03307fa3d2d430adc60e
diff --git a/dev-util/ostree/ostree-2021.3.ebuild b/dev-util/ostree/ostree-2021.3.ebuild
new file mode 100644
index 000000000000..20c372540e27
--- /dev/null
+++ b/dev-util/ostree/ostree-2021.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostreedev.github.io/ostree/"
+SRC_URI="https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="archive curl doc dracut gnutls +gpg grub http2 httpd introspection libmount selinux sodium ssl +soup systemd zeroconf"
+RESTRICT="test"
+REQUIRED_USE="httpd? ( || ( curl soup ) )"
+
+COMMON_DEPEND="
+ archive? ( app-arch/libarchive )
+ app-arch/xz-utils
+ curl? ( net-misc/curl )
+ soup? ( net-libs/libsoup )
+ dev-libs/libassuan
+ dev-libs/glib:2
+ dracut? ( sys-kernel/dracut )
+ gpg? (
+ app-crypt/gpgme
+ dev-libs/libgpg-error
+ )
+ grub? ( sys-boot/grub:2= )
+ introspection? ( dev-libs/gobject-introspection )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ >=sys-fs/fuse-2.9.2:0
+ sys-libs/zlib
+ libmount? ( sys-apps/util-linux )
+ selinux? ( sys-libs/libselinux )
+ sodium? ( >=dev-libs/libsodium-1.0.14 )
+ systemd? ( sys-apps/systemd:0= )
+ zeroconf? ( net-dns/avahi[dbus] )"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ doc? ( dev-util/gtk-doc )"
+
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lib${P}"
+
+src_prepare() {
+ sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
+ -i Makefile.in Makefile-man.am || die
+ eautoreconf
+ default
+}
+
+src_configure() {
+ local econfargs=(
+ --enable-man
+ --enable-shared
+ $(use_with archive libarchive)
+ $(use_with curl)
+ $(use_with dracut)
+ $(use_enable doc gtk-doc)
+ $(usex introspection --enable-introspection={,} yes no)
+ $(use_with gpg gpgme)
+ $(use_enable http2)
+ $(use_enable httpd trivial-httpd-cmdline)
+ $(use_with selinux )
+ $(use_with soup)
+ $(use_with libmount)
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
+ $(use_with sodium ed25519-libsodium)
+ $(use_with systemd libsystemd)
+ $(use_with zeroconf avahi)
+ )
+
+ if use systemd; then
+ econfargs+=(--with-systemdsystemunitdir="$(systemd_get_systemunitdir)")
+ fi
+
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf ${econfargs[*]}
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm -f "${ED}/etc/grub.d/15_ostree"
+}