summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-11-13 08:16:28 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-11-13 08:21:32 -0500
commit9b38608dcdd87371cf27c20be9db126f5ebea06c (patch)
tree907d6e1b5e512e80b9c31891c7e8ffeae3234339
parentdev-perl/Mozilla-CA: x86 stable wrt bug #598686 (diff)
downloadgentoo-9b38608dcdd87371cf27c20be9db126f5ebea06c.tar.gz
gentoo-9b38608dcdd87371cf27c20be9db126f5ebea06c.tar.bz2
gentoo-9b38608dcdd87371cf27c20be9db126f5ebea06c.zip
net-misc/curl: fix build with <net-libs/mbedtls-2.4.0, bug #599092
Package-Manager: portage-2.3.0
-rw-r--r--net-misc/curl/curl-7.51.0.ebuild3
-rw-r--r--net-misc/curl/files/curl-fix-mbedtls.patch37
2 files changed, 39 insertions, 1 deletions
diff --git a/net-misc/curl/curl-7.51.0.ebuild b/net-misc/curl/curl-7.51.0.ebuild
index 311cf7201592..88cb7ea00432 100644
--- a/net-misc/curl/curl-7.51.0.ebuild
+++ b/net-misc/curl/curl-7.51.0.ebuild
@@ -114,7 +114,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-7.30.0-prefix.patch \
"${FILESDIR}"/${PN}-respect-cflags-3.patch \
- "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
+ "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch \
+ "${FILESDIR}"/${PN}-fix-mbedtls.patch
sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
diff --git a/net-misc/curl/files/curl-fix-mbedtls.patch b/net-misc/curl/files/curl-fix-mbedtls.patch
new file mode 100644
index 000000000000..b82e4c6d48f0
--- /dev/null
+++ b/net-misc/curl/files/curl-fix-mbedtls.patch
@@ -0,0 +1,37 @@
+This addresses bug #599092
+
+https://bugs.gentoo.org/show_bug.cgi?id=599092
+
+commit 9ea3a6e150dfc822ba1565f649b634848597d2d9
+Author: Daniel Stenberg <daniel@haxx.se>
+Date: Fri Nov 4 11:13:16 2016 +0100
+
+ mbedtls: fix build with mbedtls versions < 2.4.0
+
+ Regression added in 62a8095e714
+
+ Reported-by: Tony Kelman
+
+ Discussed in #1087
+
+diff --git a/lib/vtls/mbedtls.c b/lib/vtls/mbedtls.c
+index 24249dd..9f29ff0 100644
+--- a/lib/vtls/mbedtls.c
++++ b/lib/vtls/mbedtls.c
+@@ -31,11 +31,15 @@
+
+ #ifdef USE_MBEDTLS
+
++#include <mbedtls/version.h>
++#if MBEDTLS_VERSION_NUMBER >= 0x02040000
+ #include <mbedtls/net_sockets.h>
++#else
++#include <mbedtls/net.h>
++#endif
+ #include <mbedtls/ssl.h>
+ #include <mbedtls/certs.h>
+ #include <mbedtls/x509.h>
+-#include <mbedtls/version.h>
+
+ #include <mbedtls/error.h>
+ #include <mbedtls/entropy.h>