summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-07 13:34:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-07 13:34:57 +0100
commit9b74e71c438636defc1debfb48096af7b10d5bf1 (patch)
treea8f46ff5f94207e4ec1c9b355059b3889211f18a
parentmedia-gfx/displaycal: Drop old (diff)
downloadgentoo-9b74e71c438636defc1debfb48096af7b10d5bf1.tar.gz
gentoo-9b74e71c438636defc1debfb48096af7b10d5bf1.tar.bz2
gentoo-9b74e71c438636defc1debfb48096af7b10d5bf1.zip
media-sound/amarok: fix build with ffmpeg 3, bug #601800
Package-Manager: portage-2.3.3
-rw-r--r--media-sound/amarok/amarok-2.8.90-r2.ebuild1
-rw-r--r--media-sound/amarok/files/amarok-2.8.90-ffmpeg3.patch58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/amarok/amarok-2.8.90-r2.ebuild b/media-sound/amarok/amarok-2.8.90-r2.ebuild
index 8a1246ffd2d9..a088d19f91d1 100644
--- a/media-sound/amarok/amarok-2.8.90-r2.ebuild
+++ b/media-sound/amarok/amarok-2.8.90-r2.ebuild
@@ -79,6 +79,7 @@ PATCHES=(
"${FILESDIR}/${P}-mysqld-rpath.patch"
"${FILESDIR}/${P}-scriptconsole.patch"
"${FILESDIR}/${P}-gcc6.patch"
+ "${FILESDIR}/${P}-ffmpeg3.patch"
)
src_configure() {
diff --git a/media-sound/amarok/files/amarok-2.8.90-ffmpeg3.patch b/media-sound/amarok/files/amarok-2.8.90-ffmpeg3.patch
new file mode 100644
index 000000000000..32af4901dcd2
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.90-ffmpeg3.patch
@@ -0,0 +1,58 @@
+Index: amarok-2.8.90/src/musicbrainz/MusicDNSAudioDecoder.cpp
+===================================================================
+--- amarok-2.8.90.orig/src/musicbrainz/MusicDNSAudioDecoder.cpp
++++ amarok-2.8.90/src/musicbrainz/MusicDNSAudioDecoder.cpp
+@@ -223,7 +223,7 @@ MusicDNSAudioDecoder::decode( const QStr
+ {
+ if( !decodedFrame )
+ {
+- decodedFrame = avcodec_alloc_frame();
++ decodedFrame = av_frame_alloc();
+ if( !decodedFrame )
+ {
+ warning() << "Unable to allocate enough memory to decode file.";
+@@ -231,7 +231,7 @@ MusicDNSAudioDecoder::decode( const QStr
+ break;
+ }
+ else
+- avcodec_get_frame_defaults( decodedFrame );
++ av_frame_unref ( decodedFrame );
+ }
+
+ decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
+@@ -341,7 +341,7 @@ MusicDNSAudioDecoder::decode( const QStr
+ {
+ if( !decodedFrame )
+ {
+- decodedFrame = avcodec_alloc_frame();
++ decodedFrame = av_frame_alloc();
+ if( !decodedFrame )
+ {
+ warning() << "Unable to allocate enough memory to decode file.";
+@@ -349,7 +349,7 @@ MusicDNSAudioDecoder::decode( const QStr
+ break;
+ }
+ else
+- avcodec_get_frame_defaults( decodedFrame );
++ av_frame_unref( decodedFrame );
+ }
+
+ decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
+@@ -459,7 +459,7 @@ MusicDNSAudioDecoder::decode( const QStr
+ {
+ if( !decodedFrame )
+ {
+- decodedFrame = avcodec_alloc_frame();
++ decodedFrame = av_frame_alloc();
+ if( !decodedFrame )
+ {
+ warning() << "Unable to allocate enough memory to decode file.";
+@@ -467,7 +467,7 @@ MusicDNSAudioDecoder::decode( const QStr
+ break;
+ }
+ else
+- avcodec_get_frame_defaults( decodedFrame );
++ av_frame_unref( decodedFrame );
+ }
+
+ decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );