summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-24 20:02:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-24 20:02:34 +0200
commit9b9e92aa68b298a01cb93ad20b08ef981f5c5cd9 (patch)
treeddeee78b0863527e52bc4378f50843b17329ea92
parentdev-python/test_server: drop 0.0.31, 0.0.32, 0.0.33, 0.0.35 (diff)
downloadgentoo-9b9e92aa68b298a01cb93ad20b08ef981f5c5cd9.tar.gz
gentoo-9b9e92aa68b298a01cb93ad20b08ef981f5c5cd9.tar.bz2
gentoo-9b9e92aa68b298a01cb93ad20b08ef981f5c5cd9.zip
dev-python/python-glanceclient: add 3.6.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index af04846dbbd8..1a0e53122ecf 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1 +1,2 @@
DIST python-glanceclient-3.5.0.tar.gz 198273 BLAKE2B 7861a2124a9474c4f6267f5b82e6d7fa9825d3cdc8411fbb05afabf69928dd230a881452de57cf54f9cd1a52157f806826036d85f6a93651980ce65e86afd520 SHA512 e5db1afeea7e3f653d7afac7961aeb3ec28df5dc40bba6b8b70795efcfc66928c2af45ecc0e4bbcc0d59a0157599e4ef3af090a8b0ccd0d727e8a94d4f8c866e
+DIST python-glanceclient-3.6.0.tar.gz 202581 BLAKE2B 20bf5ee863cc3d319cc7b670f4a218c9b84b49c392f7a7756636a93643ddf81781f808d6d966ca1982246b66b7963354c433239f554eb2aa0291bd1d57da2e79 SHA512 7bcf08386cfe6d4787dd8e6616907814a53fcc35bdac1818aef7ba094dcd37dfddddda43a1451d55f22d175f400f8680801d1a43508c5d85ce39f15164b71a5d
diff --git a/dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild
new file mode 100644
index 000000000000..9f26fcf7d80a
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}