summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-09-30 21:58:34 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-09-30 22:00:49 +0200
commit9c12909aa385098a55fdc11243a2cc84ada7b3fc (patch)
treee8a29b14d2f4a47cf977c25dc3fbffa9fad92c85
parentnet-misc/python-x2go: 0.6.0.1 bump (diff)
downloadgentoo-9c12909a.tar.gz
gentoo-9c12909a.tar.bz2
gentoo-9c12909a.zip
net-misc/pyhoca-cli: 0.6.0.0 bump
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--net-misc/pyhoca-cli/Manifest1
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/pyhoca-cli/Manifest b/net-misc/pyhoca-cli/Manifest
index bd14d2494abd..86646c54d4b0 100644
--- a/net-misc/pyhoca-cli/Manifest
+++ b/net-misc/pyhoca-cli/Manifest
@@ -1,2 +1,3 @@
DIST pyhoca-cli-0.5.0.3.tar.gz 32170 BLAKE2B 933c6a4d5b2daf3802f45de4162ee76671ca4516d07e4d91d908e29f6b2341d636bfa8bbe448b58ff8d066b1a4c61a35b48bca7c25eda72196d94f39b8da5d61 SHA512 84f92008b099fa3f753a2143115486e121d66407f318ffa4840d7b4e8fd2ee2aa620b152a384ea1c59823eb2acfdb9426257247041cbc248872e2e33dbc9c279
DIST pyhoca-cli-0.5.0.4.tar.gz 32486 BLAKE2B e47799519715c14ba89f8696ed8d394248397548ccbd0dcfc514d8c8ba96071dfa12a191eace4cc6f92aeaeb8fd0b17addf471e6f11d5ffb4e456977d38c7e14 SHA512 6dadbd01922f9957469c2f401a6b1d7da4ad7bfa9c82f38d951b230cd880b826e96a63cf3d244d27299ea9bab4d1f42239a2f0d73702e62eb4859a52c25158bd
+DIST pyhoca-cli-0.6.0.0.tar.gz 40513 BLAKE2B 203ba683c65a77c8f136ac65fea156e938b86b8338dff4c39c5b0ab9368a5e0b1e845e4862b9d95fd02cec9484691b9b11b6d2dbd41cc8a1089e32a4e9c9d717 SHA512 a6e2504cf40eb847db826eb016bcba4ead83f5b8d45de8c251c4c3b0f4cef86dbdfe4c8663f900ce9afe6fef868e67ff5ab1e3222179d19afcc7d0233b4804c6
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.0.0.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.0.0.ebuild
new file mode 100644
index 000000000000..858a77c4648b
--- /dev/null
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go command line client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.0.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}