summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafaelmartins@gentoo.org>2015-08-18 10:28:04 -0300
committerRafael G. Martins <rafaelmartins@gentoo.org>2015-08-18 10:28:04 -0300
commit9d2a84fcbcbe98ff45187764eca982848f9a165a (patch)
treea71774eea653ee0b32ef92e7bb781ab3b306a319
parentapp-text/aspell: fix compilation with clang (diff)
downloadgentoo-9d2a84fcbcbe98ff45187764eca982848f9a165a.tar.gz
gentoo-9d2a84fcbcbe98ff45187764eca982848f9a165a.tar.bz2
gentoo-9d2a84fcbcbe98ff45187764eca982848f9a165a.zip
app-text/blogc: initial commit
Package-Manager: portage-2.2.15
-rw-r--r--app-text/blogc/Manifest1
-rw-r--r--app-text/blogc/blogc-0.1_beta1.ebuild59
-rw-r--r--app-text/blogc/blogc-9999.ebuild59
-rw-r--r--app-text/blogc/metadata.xml19
4 files changed, 138 insertions, 0 deletions
diff --git a/app-text/blogc/Manifest b/app-text/blogc/Manifest
new file mode 100644
index 000000000000..2ce01e7c95b3
--- /dev/null
+++ b/app-text/blogc/Manifest
@@ -0,0 +1 @@
+DIST blogc-0.1-beta.1.tar.xz 242960 SHA256 2673df3b2fbd13234a82c26cb9fb4db5560e4b6475b883d8092362b0e0873d5a SHA512 c111145552f200f27be38b100061c119d49125d0802582d54f27e2c35bda41b029803da7bd82798a437df49ea3a1f112ba490b3c72ca4692938d7211be775231 WHIRLPOOL 1495972f4c47c7fe5f7f56d097380cc47a753dedde6d9876970449455e173c2c92de9b4bb0c820ecdd0abe4372183684aa9657f7c8e951fd1f78400786d681a4
diff --git a/app-text/blogc/blogc-0.1_beta1.ebuild b/app-text/blogc/blogc-0.1_beta1.ebuild
new file mode 100644
index 000000000000..da3dfcab90be
--- /dev/null
+++ b/app-text/blogc/blogc-0.1_beta1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/blogc/blogc.git
+ https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="http://blogc.org/"
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/beta/beta.}"
+
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+
+# pkg-config is used only to find cmocka libraries
+DEPEND="${DEPEND}
+ test? (
+ virtual/pkgconfig
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/blogc-9999.ebuild b/app-text/blogc/blogc-9999.ebuild
new file mode 100644
index 000000000000..da3dfcab90be
--- /dev/null
+++ b/app-text/blogc/blogc-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/blogc/blogc.git
+ https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="http://blogc.org/"
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/beta/beta.}"
+
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+
+# pkg-config is used only to find cmocka libraries
+DEPEND="${DEPEND}
+ test? (
+ virtual/pkgconfig
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ --disable-valgrind \
+ ${myconf}
+}
diff --git a/app-text/blogc/metadata.xml b/app-text/blogc/metadata.xml
new file mode 100644
index 000000000000..148d76a61121
--- /dev/null
+++ b/app-text/blogc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ blogc(1) is a blog compiler. It converts source files and templates
+ into blog/website resources.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="github">blogc/blogc</remote-id>
+ </upstream>
+</pkgmetadata>