summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 17:52:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 18:08:02 +0100
commit9d4113fb7d9d352b547371a990a0f02d24a564aa (patch)
tree7185c7c4503ce284547ced611ff9f4ecb3ce5c7f
parentdev-python/cliff: Bump to 3.7.0 (diff)
downloadgentoo-9d4113fb7d9d352b547371a990a0f02d24a564aa.tar.gz
gentoo-9d4113fb7d9d352b547371a990a0f02d24a564aa.tar.bz2
gentoo-9d4113fb7d9d352b547371a990a0f02d24a564aa.zip
dev-python/pylint: Bump to 2.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.6.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 394414d0fd8c..783370790a72 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1,3 @@
DIST pylint-2.6.0.tar.gz 680289 BLAKE2B f7d4159478f667a3234beefd148857f26c8f7ea3aae3bfa70fa06fe2a8d86fcf22a0727a9fa5d8fc3de4aa0bb7a4d6e13bf68029f359122762d1e0d24a0b715b SHA512 02881fe14401bbe946618ef947c8db320a6c8dd93626402260d60468538ce67b61d1e8b921bfb1a6020514dd392e9b0021c97ddb60b45866c2d2241224f93f08
DIST pylint-2.6.1.tar.gz 694232 BLAKE2B c169939a49a9a8f3225e120cf56df12fabd8d1940504231d0e1c3783dd8b87beb24e7095e15b332189043d5790b69bd2a41b0baf56cffccb4ef5d7cfe2be9cf8 SHA512 6a6bda57ed22df8378aea3de3fe3b97deb7c0742abeb08463d3d2e0f0cbf6bd2166861456b3fa7cd2d7cf148b052fc4913479c3f632b8e92ebf8d26189a122b1
+DIST pylint-2.6.2.tar.gz 680364 BLAKE2B 59bd18d5458f86a7279a7fc895f1564fc575c27e7ad7b4a668456d6005cc2a4d920e2221c2ec3f447c1c63376e1b35f1e1c5177c355f52872d3c556aa63ae462 SHA512 75e88aea23e4e68714451d22b0a6a2106a4821c05cdd7d077e12ea7f6198959ebdace6824b1e2fb42a632051e049a2c84eb93990a7b6af23c7fee7e2f56bf6ec
diff --git a/dev-python/pylint/pylint-2.6.2.ebuild b/dev-python/pylint/pylint-2.6.2.ebuild
new file mode 100644
index 000000000000..7135b98dde48
--- /dev/null
+++ b/dev-python/pylint/pylint-2.6.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Not ready for Python 3.9 yet: https://github.com/PyCQA/pylint/issues/3895
+PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+# Mirror requirements from pylint/__pkginfo__.py
+RDEPEND="
+ >=dev-python/astroid-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/astroid-2.5[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+ "${FILESDIR}/${PN}-2.5.3-tests.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # we don't want to run the benchmarking tests
+ rm -f tests/benchmark/test_baseline_benchmarks.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}