summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-05 16:20:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-06 18:45:39 +0200
commit9da4996d71282aa6b38a467fa4bedcc6c30f2c65 (patch)
tree8569f13784b303a14f700e9acc2be909abe50fd1
parentmedia-sound/yarock: Fix .desktop file and appdata install location (diff)
downloadgentoo-9da4996d71282aa6b38a467fa4bedcc6c30f2c65.tar.gz
gentoo-9da4996d71282aa6b38a467fa4bedcc6c30f2c65.tar.bz2
gentoo-9da4996d71282aa6b38a467fa4bedcc6c30f2c65.zip
app-text/libwps: 0.4.12 version bump
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/libwps/Manifest1
-rw-r--r--app-text/libwps/libwps-0.4.12.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/libwps/Manifest b/app-text/libwps/Manifest
index 85d3186eab6e..19afca9e0c2d 100644
--- a/app-text/libwps/Manifest
+++ b/app-text/libwps/Manifest
@@ -1 +1,2 @@
DIST libwps-0.4.11.tar.xz 706000 BLAKE2B e733b2fed9a05352b41126b2c0225807b3fe9a57f01f3b2a3bf35f99bd0adbd47bab8ef058f45de749332d407d589f6c33a03a3579fc76551548cb92c236e09f SHA512 6c81342b68fd93974c10ec0907dd46e9417cafa46d06205843941650828f4299a8793a7ace5c0ca755b8b9fb91fc1d6ef63304c641e7b5de36885e9995566e36
+DIST libwps-0.4.12.tar.xz 713008 BLAKE2B c95bdab54f8853cd1d13b59904ee4064cded3741cb91f2b067f139d80cdae6ea19bac68e6855cad74878403bc1a04c6f4bdd3181407b69b7e50f1e7bf4255f58 SHA512 d23667681f443b0c718b55006bee881e8a07d6b071cda742a783a89e9ed0e4c60c66c7dc9612a3fb4a419ff6d6e572f5981cec1d9470422e10cf9837e92a4649
diff --git a/app-text/libwps/libwps-0.4.12.ebuild b/app-text/libwps/libwps-0.4.12.ebuild
new file mode 100644
index 000000000000..9499a49c965a
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug doc tools"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}