summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-06 22:30:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-06 22:30:56 +0100
commit9de2e8fab7ed0a04ece6ce9738a25e2ee0f3cdc4 (patch)
tree090b5b69d57e0887ad5ef0acbba0462dc8bea608
parentapp-misc/golly: drop old (diff)
downloadgentoo-9de2e8fab7ed0a04ece6ce9738a25e2ee0f3cdc4.tar.gz
gentoo-9de2e8fab7ed0a04ece6ce9738a25e2ee0f3cdc4.tar.bz2
gentoo-9de2e8fab7ed0a04ece6ce9738a25e2ee0f3cdc4.zip
dev-util/shards: bump uo to 0.12.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-util/shards/Manifest1
-rw-r--r--dev-util/shards/shards-0.12.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
index 5654eeeb2af7..716cffff95e8 100644
--- a/dev-util/shards/Manifest
+++ b/dev-util/shards/Manifest
@@ -1,2 +1,3 @@
DIST crystal-molinillo-0.1.0.tar.gz 23932 BLAKE2B c9bcd707a3208f5d80e6e3030523d50f86cb5977799de8ea6035d014094e3c2fff9bb189fa98f566e72e1e7ad161e47e44c89d9b264d47f109b2e891ecb469e5 SHA512 8d74d95896cd7ff510c87e2ffba6ae5f04ceeddde574930ee609851312b65d713a315cc24f9aa3fab02f9447ccb25ef2dd2e8179640b8c5cfb3d7d6b52d1ded5
DIST shards-0.11.1.tar.gz 45913 BLAKE2B 43afeaaadc1b1ec68353580aacac2eb7d2d69547ba128fdb358682031d83fe28eaae159e39d519ef52f7b058228176fd6ca1aa47aeb03e4a1ccbae7306902e95 SHA512 59a1bd563101c3b3175bd586cc205a821b5087fc70b6bc14fbb612b325c18aa0a2d9b8159ad115e227c9321b1d40703fd7062b413b92252e6efd2ee081d1a221
+DIST shards-0.12.0.tar.gz 52205 BLAKE2B 6aed0be06f1f7e336861705fc0e29fbc3a97336f37d3a1eef09d3ea2ebaf2e61f1e5594f893974a6c13114ee575a69cf6a71fce0cc5f8985b8c365392735e8ca SHA512 3dfdf09be8701e568614923ffd5be90c63bdefc06f310c35b1b38e4b92f8bc1f432398656c08cadd36be52491f2ae8fda3c9b4117dbc4d53dbc8068b78300468
diff --git a/dev-util/shards/shards-0.12.0.ebuild b/dev-util/shards/shards-0.12.0.ebuild
new file mode 100644
index 000000000000..c36571a58c8e
--- /dev/null
+++ b/dev-util/shards/shards-0.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.1.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}