summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-12-14 07:01:48 +0100
committerSam James <sam@gentoo.org>2024-12-14 10:42:43 +0000
commit9de336e30627daf244c59c04833661a6e3796327 (patch)
tree9700486eca05a04d2664568b67ee5a80ef6d5caf
parentsys-devel/dwz: use error-standalone-2.0 (diff)
downloadgentoo-9de336e30627daf244c59c04833661a6e3796327.tar.gz
gentoo-9de336e30627daf244c59c04833661a6e3796327.tar.bz2
gentoo-9de336e30627daf244c59c04833661a6e3796327.zip
dev-util/debugedit: use error-standalone-2.0
Bug: https://bugs.gentoo.org/946390 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/39709 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/debugedit/debugedit-5.1-r3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/debugedit/debugedit-5.1-r3.ebuild b/dev-util/debugedit/debugedit-5.1-r3.ebuild
new file mode 100644
index 000000000000..a982466deed6
--- /dev/null
+++ b/dev-util/debugedit/debugedit-5.1-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing verify-sig toolchain-funcs
+
+DESCRIPTION="Create debuginfo and source file distributions"
+HOMEPAGE="https://sourceware.org/debugedit/"
+SRC_URI="
+ https://sourceware.org/ftp/debugedit/${PV}/${P}.tar.xz
+ verify-sig? ( https://sourceware.org/ftp/debugedit/${PV}/${P}.tar.xz.sig )
+"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+#KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/elfutils-0.176-r1:=
+ >=dev-libs/xxhash-0.8:=
+ elibc_musl? ( >=sys-libs/error-standalone-2.0 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-devel/dwz
+"
+BDEPEND="
+ sys-apps/help2man
+ virtual/pkgconfig
+ verify-sig? (
+ sec-keys/openpgp-keys-debugedit
+ )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/debugedit.gpg
+
+src_prepare() {
+ default
+
+ # bashism, https://sourceware.org/bugzilla/show_bug.cgi?id=32321
+ sed -i -e '/test/s:==:=:' tests/debugedit.at || die
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ if use elibc_musl; then
+ export CFLAGS="${CFLAGS} $(${PKG_CONFIG} --cflags error-standalone)"
+ export LIBS="${LIBS} $(${PKG_CONFIG} --libs error-standalone)"
+ fi
+
+ local myconf=(
+ # avoid BDEP on dwz
+ DWZ=dwz
+ ac_cv_dwz_j=yes
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake -Onone check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}