summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-25 05:49:25 +0000
committerSam James <sam@gentoo.org>2022-11-25 05:49:25 +0000
commit9f186ab5a20e2e7f38a1ae6840cb7501b08994ab (patch)
treedc3a2bfba33eff9bbbe937e639024d7601f5b536
parentdev-util/rats: add github upstream metadata (diff)
downloadgentoo-9f186ab5a20e2e7f38a1ae6840cb7501b08994ab.tar.gz
gentoo-9f186ab5a20e2e7f38a1ae6840cb7501b08994ab.tar.bz2
gentoo-9f186ab5a20e2e7f38a1ae6840cb7501b08994ab.zip
media-gfx/jpeginfo: fix build w/ clang 16
Closes: https://bugs.gentoo.org/874489 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild b/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
index 8649717927b5..e036302e556a 100644
--- a/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
+++ b/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Prints information and tests integrity of JPEG/JFIF files"
HOMEPAGE="https://www.kokkonen.net/tjko/projects.html"
@@ -13,11 +13,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-RDEPEND="virtual/jpeg:0"
+RDEPEND="media-libs/libjpeg-turbo:="
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-1.6.0-parallel_install.patch )
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
src_configure() {
tc-export CC
econf