summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-13 22:51:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-13 22:51:01 +0100
commit9f28a0f54184b2dc82b3e9511d1f3364a4504e00 (patch)
treef5c7ef7ebe531ba642da74cc4b9dde8b78979c75
parentsys-apps/opal-utils: add 7.0 (diff)
downloadgentoo-9f28a0f54184b2dc82b3e9511d1f3364a4504e00.tar.gz
gentoo-9f28a0f54184b2dc82b3e9511d1f3364a4504e00.tar.bz2
gentoo-9f28a0f54184b2dc82b3e9511d1f3364a4504e00.zip
app-portage/eix: Bump to 0.36.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.36.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 10e8bd776dd6..c91f0c823670 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1,2 @@
DIST eix-0.36.0.tar.xz 640820 BLAKE2B 952e6a354cc5fd1145ef36fed6047bc6f10dd7a51166028581e3b392be66b5df07eabb96cba362dc4f7a50fbe19e6ccb3744d30928c4763a91af21ad02cee38d SHA512 891e343b01d3887cbc7e61933b43e79949ff702dcd8ada2f15ff57a628dc6ebc9a4b6817d3aa3d814474db3131aefcbbf56cec2520868dcb2182cbee780125b5
+DIST eix-0.36.1.tar.xz 640084 BLAKE2B 10014bb847d71b803967354f3a415dc1c74ad37385b7b440f0c162c573453042d06bbc575582831ffc0aad6b0f7abeedbcb4e23b869505d4f85d6bd6b7cfbba4 SHA512 915a364b0f63124c53e43eb35165ce553f6eadaf8708f0c075dc2f4871fe83378cd0c8650d5605c1f87c512563fdd62f28efdc586b358fc7cd63ae42a404981d
diff --git a/app-portage/eix/eix-0.36.1.ebuild b/app-portage/eix/eix-0.36.1.ebuild
new file mode 100644
index 000000000000..7d1c230fabe8
--- /dev/null
+++ b/app-portage/eix/eix-0.36.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+DEPEND="
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${DEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+BDEPEND="
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+ --without-protobuf
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}