summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-26 10:09:54 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-26 10:16:22 +0100
commit9f3fe052899954cb779b76434f8796f726c716a0 (patch)
treed49b0b84e5bfcda26f19dc8276c0779036fa5727
parentdev-java/pdfbox: Stabilize 2.0.24 x86, #824042 (diff)
downloadgentoo-9f3fe052899954cb779b76434f8796f726c716a0.tar.gz
gentoo-9f3fe052899954cb779b76434f8796f726c716a0.tar.bz2
gentoo-9f3fe052899954cb779b76434f8796f726c716a0.zip
app-admin/ansible-molecule: remove pyyaml version cap from setup.cfg
I haven't been able to reproduce this on any of my systems (yes, including outside Docker this time) but as ago's tinderbox shows, version caps from setup.cfg _can_ sometimes be honoured. Closes: https://bugs.gentoo.org/827362 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild4
-rw-r--r--app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch11
2 files changed, 15 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild b/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
index 21dc93e1196..90b97115e87 100644
--- a/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
+++ b/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
@@ -54,6 +54,10 @@ BDEPEND="$(python_gen_cond_dep '
)
')"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.2_pyyaml6.patch
+)
+
S="${WORKDIR}"/${MY_P}
distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.9.0'
diff --git a/app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch b/app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch
new file mode 100644
index 00000000000..80a7d8b7a87
--- /dev/null
+++ b/app-admin/ansible-molecule/files/ansible-molecule-3.5.2_pyyaml6.patch
@@ -0,0 +1,11 @@
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -74,7 +74,7 @@
+ packaging
+ paramiko >= 2.5.0, < 3
+ pluggy >= 0.7.1, < 2.0
+- PyYAML >= 5.1, < 6
++ PyYAML >= 5.1
+ rich >= 9.5.1
+ subprocess-tee >= 0.3.5
+ selinux; sys_platform=="linux2"