summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 11:58:47 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 12:38:46 -0500
commit9f545df011bd28126cdcdb0b17e95c56ae65d187 (patch)
treef848a5e0535d39de9f3964f2955a01a09a7d6a68
parentgames-server/bf1942-lnxded: remove deprecated games eclass (diff)
downloadgentoo-9f545df011bd28126cdcdb0b17e95c56ae65d187.tar.gz
gentoo-9f545df011bd28126cdcdb0b17e95c56ae65d187.tar.bz2
gentoo-9f545df011bd28126cdcdb0b17e95c56ae65d187.zip
games-server/cyphesis: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
-rw-r--r--games-server/cyphesis/cyphesis-0.6.2-r1.ebuild62
-rw-r--r--games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch4
2 files changed, 64 insertions, 2 deletions
diff --git a/games-server/cyphesis/cyphesis-0.6.2-r1.ebuild b/games-server/cyphesis/cyphesis-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..b2e6c7426457
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.6.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit toolchain-funcs autotools python-single-r1 eutils
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/index.php/components/cyphesis/"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/postgresql:=
+ >=dev-games/mercator-0.3.3
+ >=dev-games/wfmath-1.0.1
+ dev-libs/libgcrypt:0
+ dev-libs/libsigc++:2
+ sys-libs/ncurses:0
+ sys-libs/readline:0
+ >=media-libs/atlas-c++-0.6.3
+ >=media-libs/skstream-0.3.9
+ >=media-libs/varconf-0.6.4
+ "
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.40
+ dev-libs/libxml2
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --localstatedir=/var
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" install
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch b/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch
index 99ca3872c040..7fde1eb12135 100644
--- a/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch
+++ b/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.am.old 2013-09-25 14:26:30.518751250 +0200
-+++ Makefile.am 2013-09-25 14:27:21.846257911 +0200
+--- a/Makefile.am 2013-09-25 14:26:30.518751250 +0200
++++ b/Makefile.am 2013-09-25 14:27:21.846257911 +0200
@@ -13,8 +13,6 @@
# FIXME Remove the mkdir hack if it gets fixed in a future automake