summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-15 01:53:35 +0100
committerSam James <sam@gentoo.org>2024-08-15 01:53:35 +0100
commit9fd11c29b85d3f32d8468e657486e5c0f2b7c618 (patch)
tree832b54d56fa5bfc049a8e44625fb5207bdcf3916
parentmedia-libs/libaom: fix build w/ gcc-15 (diff)
downloadgentoo-9fd11c29b85d3f32d8468e657486e5c0f2b7c618.tar.gz
gentoo-9fd11c29b85d3f32d8468e657486e5c0f2b7c618.tar.bz2
gentoo-9fd11c29b85d3f32d8468e657486e5c0f2b7c618.zip
app-text/dvisvgm: add 3.4
Closes: https://bugs.gentoo.org/937694 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-3.4.ebuild59
-rw-r--r--app-text/dvisvgm/files/dvisvgm-3.4-gcc15-cstdint.patch59
3 files changed, 119 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 447d2f807ec5..3fb50a588468 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -4,3 +4,4 @@ DIST dvisvgm-3.1.2.tar.gz 2940106 BLAKE2B 05672e2f6b2248e0a28548dae52aa6f6d5f3c5
DIST dvisvgm-3.1.tar.gz 2908747 BLAKE2B f7544d291fbabf1bb126c97077b15296369815ae0ae8baa2b23d5831d8a6788673af13e0d44c12028be1cef319f83117b0842693810fcc3e5c14263999b41d9e SHA512 8e019eb54f0ad4a5f0e6241e2a5223582da723c7692598278668c1220d7769f161895eb292be0a95771ea7b3e65e8fb83052b7b1f6a6432276fd013e00fd7e51
DIST dvisvgm-3.2.tar.gz 2940355 BLAKE2B 51a00b948a7ecaa68cee78d484813622c449eb2876a326051f93bb62304bfd174c443cf2eb192bb7c46e28065fe53001ada283002d30949bf39a69270c387dd4 SHA512 718ce9cd1cc8c826859df74eccd8e05dfb1c42f0defb57cdc99910957d009044e0e8a1854ff7fcde739cb832b2559976d3025dbf4cfda9e4cdea85398558d730
DIST dvisvgm-3.3.tar.gz 2949759 BLAKE2B 37e69aa87fb1b9e14e013d28ef17ecbd89ac5cbbec6206a2e4610a0dadb987cbfcfea72ff17e0150e8b4c20ab27c43a0619538709439dc0eea112ac43b7ec8c7 SHA512 d54121dd1dfeba94dc5ed787dcc55f5287d695d8e2e07cbdffd064e9d97e5368a2df4af794b13d1ef4ea579ea13d7a86c781de30f9d58f5fe3034e6e50b1f2e5
+DIST dvisvgm-3.4.tar.gz 2906583 BLAKE2B 30796beab5983e2828eb669f8c3fc67b4c9ac3527cc4f71544d7724ec9f161c2f7c4b9bee26bbd82a3c43759df2302eba7a42ab127a4c60705e4562ead380547 SHA512 7041ecd8d1085f2e022746e83c40eaca7e9d4e7ad8be285f8a107fb1519272e8c07b3ddaeda9a01adc8fbdbb5438b569276d401b5cb6ccfc8f83d2a4c88efe6a
diff --git a/app-text/dvisvgm/dvisvgm-3.4.ebuild b/app-text/dvisvgm/dvisvgm-3.4.ebuild
new file mode 100644
index 000000000000..5ccb6669e46d
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-3.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="https://dvisvgm.de/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+# dvisvgm: GPL-3
+# Boost (tiny part, one header): Boost-1.0
+# md5: || ( public-domain BSD-1 )
+# clipper: Boost-1.0
+# variant: Boost-1.0
+LICENSE="GPL-3 Boost-1.0 || ( public-domain BSD-1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.5:=
+ app-text/ghostscript-gpl:=
+ dev-libs/kpathsea:=
+ >=dev-libs/xxhash-0.8.1
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ sys-libs/zlib
+ virtual/tex-base
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.11 )
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4-gcc15-cstdint.patch
+)
+
+src_configure() {
+ # ODR violation but only reported with -fno-semantic-interposition?
+ filter-lto
+
+ local myargs=(
+ --disable-bundled-libs
+ --without-ttfautohint
+ )
+
+ econf "${myargs[@]}"
+}
diff --git a/app-text/dvisvgm/files/dvisvgm-3.4-gcc15-cstdint.patch b/app-text/dvisvgm/files/dvisvgm-3.4-gcc15-cstdint.patch
new file mode 100644
index 000000000000..ce3d7f472cbf
--- /dev/null
+++ b/app-text/dvisvgm/files/dvisvgm-3.4-gcc15-cstdint.patch
@@ -0,0 +1,59 @@
+https://github.com/mgieseki/dvisvgm/pull/273
+
+From 094a630bc8f49e233b2b21f34b6fdb3312d6ba2a Mon Sep 17 00:00:00 2001
+Message-ID: <094a630bc8f49e233b2b21f34b6fdb3312d6ba2a.1723683010.git.sam@gentoo.org>
+From: Sam James <sam@gentoo.org>
+Date: Thu, 15 Aug 2024 01:34:04 +0100
+Subject: [PATCH] Add missing `<cstdint>` includes
+
+`uint8_t`, `uint32_t` are used without including `<cstdint>`
+which fails to build w/ GCC 15 after a change in libstdc++ [0]
+
+[0] https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=3a817a4a5a6d94da9127af3be9f84a74e3076ee2
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ src/Character.hpp | 1 +
+ src/HashFunction.hpp | 1 +
+ src/utility.hpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/src/Character.hpp b/src/Character.hpp
+index 0569205a..2b71c163 100644
+--- a/src/Character.hpp
++++ b/src/Character.hpp
+@@ -21,6 +21,7 @@
+ #ifndef CHARACTER_HPP
+ #define CHARACTER_HPP
+
++#include <cstdint>
+
+ class Character {
+ public:
+diff --git a/src/HashFunction.hpp b/src/HashFunction.hpp
+index 703a0bc0..7f5da89d 100644
+--- a/src/HashFunction.hpp
++++ b/src/HashFunction.hpp
+@@ -21,6 +21,7 @@
+ #ifndef HASHFUNCTION_HPP
+ #define HASHFUNCTION_HPP
+
++#include <cstdint>
+ #include <istream>
+ #include <memory>
+ #include <string>
+diff --git a/src/utility.hpp b/src/utility.hpp
+index bff301c4..75719480 100644
+--- a/src/utility.hpp
++++ b/src/utility.hpp
+@@ -25,6 +25,7 @@
+ #include <config.h>
+ #endif
+
++#include <cstdint>
+ #include <iomanip>
+ #include <functional>
+ #include <memory>
+--
+2.45.2
+