summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-25 07:21:27 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-25 07:21:27 +0200
commit9fd19d7ee91304619c57968c61e0b073806928c4 (patch)
treea1600756bc57eab1a85cc40a77db31c5d9e5b4e6
parentdev-ruby/sqlite3: drop 1.6.4, 1.6.5 (diff)
downloadgentoo-9fd19d7ee91304619c57968c61e0b073806928c4.tar.gz
gentoo-9fd19d7ee91304619c57968c61e0b073806928c4.tar.bz2
gentoo-9fd19d7ee91304619c57968c61e0b073806928c4.zip
dev-ruby/arel-helpers: drop 2.14.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/arel-helpers/arel-helpers-2.14.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/arel-helpers/arel-helpers-2.14.0.ebuild b/dev-ruby/arel-helpers/arel-helpers-2.14.0.ebuild
deleted file mode 100644
index c4ae0a3adf84..000000000000
--- a/dev-ruby/arel-helpers/arel-helpers-2.14.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-RUBY_S=${PN}-*
-RUBY_FAKEGEM_VERSION="$(ver_cut 1-3)"
-inherit ruby-fakegem
-
-DESCRIPTION="Tools to help construct database queries"
-HOMEPAGE="https://github.com/camertron/arel-helpers"
-# No test data in gems
-SRC_URI="https://github.com/camertron/arel-helpers/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-
-ruby_add_rdepend "
- || (
- dev-ruby/activerecord:7.0
- dev-ruby/activerecord:6.1
- )
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/rr
- dev-ruby/activerecord[sqlite]
- dev-ruby/bundler
- dev-ruby/combustion
- >=dev-ruby/database_cleaner-1.8
- =dev-ruby/sqlite3-1.4*
- )
-"
-
-all_ruby_prepare() {
- # pry is for debugging, not useful here
- sed -i -e '/pry-/ s:^:#:' spec/spec_helper.rb || die
-
- sed \
- -e '/rake/ s/~>/>=/' \
- -e '/appraisal/ s:^:#:' \
- -e '/database_cleaner/ s/1.8/1.7/' \
- -e '/database_cleaner/ s/~>/>=/' \
- -e '/sqlite3/ s/~>/>=/' \
- -i arel-helpers.gemspec || die
-}
-
-each_ruby_test() {
- ${RUBY} -S bundle exec rake spec || die
-}