summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-23 14:33:34 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-23 14:33:34 -0800
commita0629ab80a91dae3af16d6bf1652e95140d43d0d (patch)
treeba970643c09d9f044b7f33702c59a97bb33426dd
parentapp-shells/fish: enable py3.10 and disable py3.7 in -9999 (diff)
downloadgentoo-a0629ab80a91dae3af16d6bf1652e95140d43d0d.tar.gz
gentoo-a0629ab80a91dae3af16d6bf1652e95140d43d0d.tar.bz2
gentoo-a0629ab80a91dae3af16d6bf1652e95140d43d0d.zip
app-shells/fish: never build docs for release version
Closes: https://bugs.gentoo.org/770862 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-shells/fish/fish-3.3.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-shells/fish/fish-3.3.1-r1.ebuild b/app-shells/fish/fish-3.3.1-r1.ebuild
index d0d5a67aeecf..bd040a633309 100644
--- a/app-shells/fish/fish-3.3.1-r1.ebuild
+++ b/app-shells/fish/fish-3.3.1-r1.ebuild
@@ -76,7 +76,11 @@ src_configure() {
-DWITH_GETTEXT="$(usex nls)"
)
# release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
- [[ ${PV} == 9999 ]] && mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
+ else
+ mycmakeargs+=( -DBUILD_DOCS=OFF )
+ fi
cmake_src_configure
}