summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-03-28 15:54:31 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-03-29 09:43:42 -0400
commita06a3691b52cafd5101b43ff0aa00aef5d1f29e8 (patch)
tree3fde2d02fae2eb5e8fb49e240a35cd3561269058
parentprofiles: add masks for arch-specific sci-mathematics/maxima flags. (diff)
downloadgentoo-a06a3691b52cafd5101b43ff0aa00aef5d1f29e8.tar.gz
gentoo-a06a3691b52cafd5101b43ff0aa00aef5d1f29e8.tar.bz2
gentoo-a06a3691b52cafd5101b43ff0aa00aef5d1f29e8.zip
sci-mathematics/maxima: hide dbl.el when USE=gcl is unset.
One of the emacs modes installed by maxima requires the gcl lisp interpreter (with emacs support) to be installed. To avoid confusing error messages, we remove it from the installation image when USE=gcl is unset. Closes: https://bugs.gentoo.org/502112 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/maxima/maxima-5.44.0-r6.ebuild (renamed from sci-mathematics/maxima/maxima-5.44.0-r5.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/sci-mathematics/maxima/maxima-5.44.0-r5.ebuild b/sci-mathematics/maxima/maxima-5.44.0-r6.ebuild
index e0dbc91fdb0b..540d0048980b 100644
--- a/sci-mathematics/maxima/maxima-5.44.0-r5.ebuild
+++ b/sci-mathematics/maxima/maxima-5.44.0-r6.ebuild
@@ -204,6 +204,13 @@ src_install() {
insinto /usr/share/${PN}/${PV}/doc/imaxima
doins interfaces/emacs/imaxima/README
doins -r interfaces/emacs/imaxima/imath-example
+
+ if ! use gcl; then
+ # This emacs package is used to run gcl, maxima, gdb, etc.
+ # all at once and possibly in the same buffer. As such, it's
+ # no use without gcl (more to the point: it requires gcl.el).
+ find "${ED}" -name 'dbl.el' -type f -delete || die
+ fi
fi
if use ecls; then