summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-02-25 12:56:21 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-25 12:57:09 -0800
commita0a11d2292e8c4e813b7215c8303fec57a6d1da2 (patch)
treed9717cc1047d961e2bdf73d678e1cb63e75c38ed
parentsci-chemistry/pymol: Drop old (diff)
downloadgentoo-a0a11d2292e8c4e813b7215c8303fec57a6d1da2.tar.gz
gentoo-a0a11d2292e8c4e813b7215c8303fec57a6d1da2.tar.bz2
gentoo-a0a11d2292e8c4e813b7215c8303fec57a6d1da2.zip
dev-vcs/git: resync livevcs builds.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild44
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild44
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild44
-rw-r--r--dev-vcs/git/git-9999.ebuild44
4 files changed, 104 insertions, 72 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index c4878cd6d48..996fd1fa4be 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -38,17 +38,18 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
+ libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -58,7 +59,7 @@ CDEPEND="
webdav? ( dev-libs/expat )
)
emacs? ( virtual/emacs )
- gnome-keyring? ( gnome-base/libgnome-keyring )"
+"
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
@@ -117,7 +118,7 @@ REQUIRED_USE="
PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
- "${FILESDIR}"/git-2.10.0-optional-cvs.patch
+ "${FILESDIR}"/git-2.12.0-optional-cvs.patch
# install mediawiki perl modules also in vendor_dir
# hack, needs better upstream solution
@@ -192,6 +193,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
@@ -361,12 +364,12 @@ src_compile() {
cd "${S}"
fi
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- git_emake || die "emake git-credential-gnome-keyring failed"
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ git_emake || die "emake git-credential-libsecret failed"
fi
- cd "${S}"/contrib/subtree
+ cd "${S}"/contrib/subtree || die
git_emake
use doc && git_emake doc
@@ -461,9 +464,9 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- dobin git-credential-gnome-keyring
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ dobin git-credential-libsecret
fi
if use subversion ; then
@@ -481,7 +484,6 @@ src_install() {
dodir /usr/share/${PN}/contrib
# The following are excluded:
# completion - installed above
- # credential/gnome-keyring TODO
# diff-highlight - done above
# emacs - installed above
# examples - these are stuff that is not used in Git anymore actually
@@ -494,11 +496,17 @@ src_install() {
# subtree - build seperately
# svnimport - use git-svn
# thunderbird-patch-inline - fixes thunderbird
- for i in \
- buildsystems convert-objects fast-import \
- hg-to-git hooks remotes2config.sh rerere-train.sh \
- stats workdir \
- ; do
+ local contrib_objects=(
+ buildsystems
+ fast-import
+ hg-to-git
+ hooks
+ remotes2config.sh
+ rerere-train.sh
+ stats
+ workdir
+ )
+ for i in "${contrib_objects[@]}" ; do
cp -rf \
"${S}"/contrib/${i} \
"${ED}"/usr/share/${PN}/contrib \
@@ -555,7 +563,7 @@ src_install() {
}
src_test() {
- local disabled=""
+ local disabled="t9128-git-svn-cmd-branch.sh"
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 840ce77c961..1924612f28b 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -38,17 +38,18 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
+ libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -58,7 +59,7 @@ CDEPEND="
webdav? ( dev-libs/expat )
)
emacs? ( virtual/emacs )
- gnome-keyring? ( gnome-base/libgnome-keyring )"
+"
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
@@ -117,7 +118,7 @@ REQUIRED_USE="
PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
- "${FILESDIR}"/git-2.10.0-optional-cvs.patch
+ "${FILESDIR}"/git-2.12.0-optional-cvs.patch
# install mediawiki perl modules also in vendor_dir
# hack, needs better upstream solution
@@ -192,6 +193,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
@@ -361,12 +364,12 @@ src_compile() {
cd "${S}"
fi
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- git_emake || die "emake git-credential-gnome-keyring failed"
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ git_emake || die "emake git-credential-libsecret failed"
fi
- cd "${S}"/contrib/subtree
+ cd "${S}"/contrib/subtree || die
git_emake
use doc && git_emake doc
@@ -461,9 +464,9 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- dobin git-credential-gnome-keyring
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ dobin git-credential-libsecret
fi
if use subversion ; then
@@ -481,7 +484,6 @@ src_install() {
dodir /usr/share/${PN}/contrib
# The following are excluded:
# completion - installed above
- # credential/gnome-keyring TODO
# diff-highlight - done above
# emacs - installed above
# examples - these are stuff that is not used in Git anymore actually
@@ -494,11 +496,17 @@ src_install() {
# subtree - build seperately
# svnimport - use git-svn
# thunderbird-patch-inline - fixes thunderbird
- for i in \
- buildsystems convert-objects fast-import \
- hg-to-git hooks remotes2config.sh rerere-train.sh \
- stats workdir \
- ; do
+ local contrib_objects=(
+ buildsystems
+ fast-import
+ hg-to-git
+ hooks
+ remotes2config.sh
+ rerere-train.sh
+ stats
+ workdir
+ )
+ for i in "${contrib_objects[@]}" ; do
cp -rf \
"${S}"/contrib/${i} \
"${ED}"/usr/share/${PN}/contrib \
@@ -555,7 +563,7 @@ src_install() {
}
src_test() {
- local disabled=""
+ local disabled="t9128-git-svn-cmd-branch.sh"
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index b4457255724..faa18537adf 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -38,17 +38,18 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
+ libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -58,7 +59,7 @@ CDEPEND="
webdav? ( dev-libs/expat )
)
emacs? ( virtual/emacs )
- gnome-keyring? ( gnome-base/libgnome-keyring )"
+"
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
@@ -117,7 +118,7 @@ REQUIRED_USE="
PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
- "${FILESDIR}"/git-2.10.0-optional-cvs.patch
+ "${FILESDIR}"/git-2.12.0-optional-cvs.patch
# install mediawiki perl modules also in vendor_dir
# hack, needs better upstream solution
@@ -192,6 +193,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
@@ -361,12 +364,12 @@ src_compile() {
cd "${S}"
fi
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- git_emake || die "emake git-credential-gnome-keyring failed"
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ git_emake || die "emake git-credential-libsecret failed"
fi
- cd "${S}"/contrib/subtree
+ cd "${S}"/contrib/subtree || die
git_emake
use doc && git_emake doc
@@ -461,9 +464,9 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- dobin git-credential-gnome-keyring
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ dobin git-credential-libsecret
fi
if use subversion ; then
@@ -481,7 +484,6 @@ src_install() {
dodir /usr/share/${PN}/contrib
# The following are excluded:
# completion - installed above
- # credential/gnome-keyring TODO
# diff-highlight - done above
# emacs - installed above
# examples - these are stuff that is not used in Git anymore actually
@@ -494,11 +496,17 @@ src_install() {
# subtree - build seperately
# svnimport - use git-svn
# thunderbird-patch-inline - fixes thunderbird
- for i in \
- buildsystems convert-objects fast-import \
- hg-to-git hooks remotes2config.sh rerere-train.sh \
- stats workdir \
- ; do
+ local contrib_objects=(
+ buildsystems
+ fast-import
+ hg-to-git
+ hooks
+ remotes2config.sh
+ rerere-train.sh
+ stats
+ workdir
+ )
+ for i in "${contrib_objects[@]}" ; do
cp -rf \
"${S}"/contrib/${i} \
"${ED}"/usr/share/${PN}/contrib \
@@ -555,7 +563,7 @@ src_install() {
}
src_test() {
- local disabled=""
+ local disabled="t9128-git-svn-cmd-branch.sh"
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 5e3e6d6543d..a1f5e74e5a8 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -38,17 +38,18 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
+ libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -58,7 +59,7 @@ CDEPEND="
webdav? ( dev-libs/expat )
)
emacs? ( virtual/emacs )
- gnome-keyring? ( gnome-base/libgnome-keyring )"
+"
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
@@ -117,7 +118,7 @@ REQUIRED_USE="
PATCHES=(
# bug #350330 - automagic CVS when we don't want it is bad.
- "${FILESDIR}"/git-2.10.0-optional-cvs.patch
+ "${FILESDIR}"/git-2.12.0-optional-cvs.patch
# install mediawiki perl modules also in vendor_dir
# hack, needs better upstream solution
@@ -192,6 +193,8 @@ exportmakeopts() {
|| myopts+=" NO_PTHREADS=YesPlease"
use cvs \
|| myopts+=" NO_CVS=YesPlease"
+ use elibc_musl \
+ && myopts+=" NO_REGEX=YesPlease"
# Disabled until ~m68k-mint can be keyworded again
# if [[ ${CHOST} == *-mint* ]] ; then
# myopts+=" NO_MMAP=YesPlease"
@@ -361,12 +364,12 @@ src_compile() {
cd "${S}"
fi
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- git_emake || die "emake git-credential-gnome-keyring failed"
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ git_emake || die "emake git-credential-libsecret failed"
fi
- cd "${S}"/contrib/subtree
+ cd "${S}"/contrib/subtree || die
git_emake
use doc && git_emake doc
@@ -461,9 +464,9 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use gnome-keyring ; then
- cd "${S}"/contrib/credential/gnome-keyring
- dobin git-credential-gnome-keyring
+ if use libsecret ; then
+ cd "${S}"/contrib/credential/libsecret
+ dobin git-credential-libsecret
fi
if use subversion ; then
@@ -481,7 +484,6 @@ src_install() {
dodir /usr/share/${PN}/contrib
# The following are excluded:
# completion - installed above
- # credential/gnome-keyring TODO
# diff-highlight - done above
# emacs - installed above
# examples - these are stuff that is not used in Git anymore actually
@@ -494,11 +496,17 @@ src_install() {
# subtree - build seperately
# svnimport - use git-svn
# thunderbird-patch-inline - fixes thunderbird
- for i in \
- buildsystems convert-objects fast-import \
- hg-to-git hooks remotes2config.sh rerere-train.sh \
- stats workdir \
- ; do
+ local contrib_objects=(
+ buildsystems
+ fast-import
+ hg-to-git
+ hooks
+ remotes2config.sh
+ rerere-train.sh
+ stats
+ workdir
+ )
+ for i in "${contrib_objects[@]}" ; do
cp -rf \
"${S}"/contrib/${i} \
"${ED}"/usr/share/${PN}/contrib \
@@ -555,7 +563,7 @@ src_install() {
}
src_test() {
- local disabled=""
+ local disabled="t9128-git-svn-cmd-branch.sh"
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \