summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-14 07:34:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 08:05:19 +0200
commita0c83ace3d9e38317566ad0b039fba1fda1fdcbc (patch)
treea011927f45adc62a9dc65ab9900c58a6e158fd31
parentdev-python/keyrings-alt: Bump to 5.0.2 (diff)
downloadgentoo-a0c83ace3d9e38317566ad0b039fba1fda1fdcbc.tar.gz
gentoo-a0c83ace3d9e38317566ad0b039fba1fda1fdcbc.tar.bz2
gentoo-a0c83ace3d9e38317566ad0b039fba1fda1fdcbc.zip
dev-python/dirty-equals: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dirty-equals/Manifest1
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index b20eb951749a..e8967bc377b3 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1 +1,2 @@
DIST dirty-equals-0.7.1.gh.tar.gz 49000 BLAKE2B 06c9a7522f1dda95ff682dc9c28207b29754d11b4afe7eeacd5439a9ae9f34ce0a2f5724703129aa90b5577f36646deafa5428120e823502aae616d57b3d8f0d SHA512 c50a15e4cee77b3db1b07ef9f7d1eb5b3ab6bed6d914ac5c9e2982f8cf9432beaecb5fd7997d46a94f405e0c932ea5a8d72f1c1d4b6dda86161c22cc772ab4d7
+DIST dirty-equals-0.8.0.gh.tar.gz 50468 BLAKE2B 5d5c58807c0ef26db80895a26b5246a0305ab55389f95d7e13586cad2adc4edd17d24905fad5e462c2bafb59cad7453b55400e4576e0f845ec75d617405f67bb SHA512 8fc6ee0eefe700c89acf5b2181e502422835a89e8f0bb771b07133bda48b804f09b18e452919c8eb7d50e579b032732edad3e9ec150cd7bc7a33a4db77d9ab5c
diff --git a/dev-python/dirty-equals/dirty-equals-0.8.0.ebuild b/dev-python/dirty-equals/dirty-equals-0.8.0.ebuild
new file mode 100644
index 000000000000..4ad91cb194b4
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/latest/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ if ! has_version "dev-python/pydantic[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_other.py
+ )
+ fi
+
+ local -x TZ=UTC
+ epytest "${args[@]}"
+}