summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:14:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:47 +0200
commita0fffd1f2eca973392fab81c01d530edd7eb59f0 (patch)
tree7e8963e10e3df9cf69d05bdf8843be8cddc4ac61
parentdev-ros/rqt_dep: Remove old (diff)
downloadgentoo-a0fffd1f2eca973392fab81c01d530edd7eb59f0.tar.gz
gentoo-a0fffd1f2eca973392fab81c01d530edd7eb59f0.tar.bz2
gentoo-a0fffd1f2eca973392fab81c01d530edd7eb59f0.zip
dev-ros/rqt_console: bump to 0.4.11
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/rqt_console/Manifest1
-rw-r--r--dev-ros/rqt_console/rqt_console-0.4.11.ebuild25
-rw-r--r--dev-ros/rqt_console/rqt_console-9999.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-ros/rqt_console/Manifest b/dev-ros/rqt_console/Manifest
index 54d579dcfdb7..14d52097c29c 100644
--- a/dev-ros/rqt_console/Manifest
+++ b/dev-ros/rqt_console/Manifest
@@ -1,2 +1,3 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 BLAKE2B 5efebfa64dcc587822e558b5527a2ef2e33adc8adcb45800876e278be5ccdacbaef93b0f9dfbb7b98972fd5cffb4fcddee80e9522a4135a736d744765c2490ed SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7
+DIST rqt_console-0.4.11.tar.gz 27734 BLAKE2B ea8f71871bb4bc5f529c0502b0c02590c937340f9c15d4db09fbf90c47fda2731b978e88292452f217cd0c301e5f40ccaff96ca0f58bb6b3aa580f48cd41540b SHA512 c9ba7bf85c19e8fa7df7786c8d575b7a2658d4567b6b7bf67d949d844ad3b1f1892d844df6fb592d90ff01f64ad16f6b0602a8c64cf44ac09e24bc08c262b827
DIST rqt_console-0.4.8.tar.gz 26946 BLAKE2B fcfb17681d26611e782e87173d93d4644ca96fd4fb765e547252d12f3ffb7bf25df8cde2b19acbb2e240d4c1bc305a2a371682e1e81df35a006da2540c15c8e4 SHA512 9674898ef33397d59554b20980c45ae4cc04be019a2f039eedd401ccd6f774e9f6e4130c1aad9bb953d39f47a971fe0514853d2be8be05cc53d6d8c203054813
diff --git a/dev-ros/rqt_console/rqt_console-0.4.11.ebuild b/dev-ros/rqt_console/rqt_console-0.4.11.ebuild
new file mode 100644
index 000000000000..7804ae8e93f0
--- /dev/null
+++ b/dev-ros/rqt_console/rqt_console-0.4.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_console"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and filtering ROS messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_logger_level[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_console/rqt_console-9999.ebuild b/dev-ros/rqt_console/rqt_console-9999.ebuild
index eefcdaa3e26c..7804ae8e93f0 100644
--- a/dev-ros/rqt_console/rqt_console-9999.ebuild
+++ b/dev-ros/rqt_console/rqt_console-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_console"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin