summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-31 20:48:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-31 22:13:45 +0100
commita11d2ee11a1bb0aa626cbbac885b940635a77125 (patch)
treea228a1bc682fd36752b1a4fbbcfb8b5a4e2af45d
parentsys-fs/dfc: Drop 3.0.5-r1 (diff)
downloadgentoo-a11d2ee1.tar.gz
gentoo-a11d2ee1.tar.bz2
gentoo-a11d2ee1.zip
app-editors/okteta: 0.25.5 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.25.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index 421e9f10d516..a3b2ae4718be 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1,2 @@
DIST okteta-0.25.4.tar.xz 950344 BLAKE2B 3a3daf5cdb9e349e145a22afe836c78e18972e1f984472267cd182630b8f8132e10efb49cbc9fac40768aef4dadbb678afa26eb965642f07f407030f15b71dbd SHA512 d9887a90efbad3bb2caa0d3bb12af27708b77d54a90cd0da82eace7ea6dfc2efbcea3d7dc720bf4a088a823a8ed9edf75ab1c3680aa6d99c640d5c9e4c385e16
+DIST okteta-0.25.5.tar.xz 953492 BLAKE2B ca8c40df7cf3fe40a4be6f6e2b9d1f787baa658910c3c14ced73f3f3d95c942c00ccfe559562b2e0330726723ffba8e4c7c526369453517e1fd45d3d5ce0336e SHA512 dfe45a2bc3b3fbbce8342e6282981a63a342aee47d0d90cf07449f6974ebdbac53adc7fa9f0b37a7d003370994233f002df277ecebdb6f4c03995ce50d1dbd71
diff --git a/app-editors/okteta/okteta-0.25.5.ebuild b/app-editors/okteta/okteta-0.25.5.ebuild
new file mode 100644
index 000000000000..1956e22af1c8
--- /dev/null
+++ b/app-editors/okteta/okteta-0.25.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta/"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}